微咏 / 我的图书馆 / N多通达信指标公式

分享

   

永利注册送38体验金登入

2010-09-09  鸿运彩票网直营网
N多通达信指标公式
看清主力
V1:=(C*2+H+L)/4*10;
V2:=EMA(V1,13)-EMA(V1,34);
V3:=EMA(V2,5);
V4:=2*(V2-V3)*5.5;
庄家秘密撤: IF(V4<=0,V4,0),COLOR00FF00,LINETHICK2;
庄家秘密进: IF(V4>=0,V4,0),COLORFF00FF,LINETHICK2;
V5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;
V6:=EMA(3*V5-2*SMA(V5,18,1),5);
V7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;
V8:=(INDEXC*2+INDEXH+INDEXL)/4;
V9:=EMA(V8,13)-EMA(V8,34);
VA:=EMA(V9,3);
VB:=(V9-VA)/2;
大盘资金进场: IF(VB>=0,VB,0),COLORYELLOW,LINETHICK2;
大盘资金撤走: IF(VB<=0,VB,0),COLORBLUE,LINETHICK2;

AA:=WINNER(CLOSE+CLOSE*15/100)*100;
BB:=WINNER(CLOSE+CLOSE*0/100)*100;
CC:=AA-BB;
DD:=(WINNER(CLOSE-CLOSE*0.1/100)-WINNER(CLOSE-CLOSE*15/100))*100;
EE:=CC<3 AND DD<0.5;
A1:=DYNAINFO(6);
A2:=IF(LOW>A1,0,IF(HIGH<A1,1,(A1-LOW+0.01)/(HIGH-LOW+0.01)));
A3:=VOL/WINNER(LOW);
A4:=REF(HHV(CLOSE,120),1);
A5:=REF(LLV(CLOSE,120),1);
A6:=100*(CLOSE-A5)/(A4-A5);
A7:=A2>0 OR A2=1;
A8:=A7 AND A3/REF(A3,3)>=3 AND A6<80;
A9:=REF(A8,1) OR REF(A8,2) OR REF(A8,3) OR REF(A8,4);
A10:=A8 AND A9;
A11:=IF(FILTER(A8,3),5,0);
A12:=IF(FILTER(A10,3) OR EE,10,0);
资金进场日:IF(A11,8,0),LINETHICK0;
STICKLINE(A12,0,15,5,1),COLORFF00FF;
资金加仓日:IF(A12,88,0),LINETHICK0;
STICKLINE(A12,0,15,5,1),COLORFF00FF;

STICKLINE(A11,0,5,1,0),COLORFFEE00;

STICKLINE(A12,0,15,1,0),COLOR1020FF;
DRAWTEXT(A11,8,'资金进场');

DRAWTEXT(A12,17,'资金加仓');


VAR1:=REF(LOW,1);
VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),13,1)*4;
VAR3:=EMA(VAR2,13);
VAR4:=LLV(LOW,34);
VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);
主力进场:
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,7,1 ),COLORRED;
洗盘:IF(VAR5<REF(VAR5,1),VAR5,0),COLORGREEN,LINETHICK2;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,2,1),COLORGREEN;

VAR6:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR7:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR8:=VAR6<REF(VAR7,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(VAR8 AND COUNT(VAR8,30)=1,40,'有大资金进场迹象,关注!');
 
售价3800元 不知如何用
VAR2:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR3:=SMA(VAR2,5,1);
VAR4:=REF(VAR3,1);
VAR5:=SMA(VAR3,10,1);
VAR6:=(HHV(HIGH,52)-CLOSE)/(HHV(HIGH,52)-LLV(LOW,52))*100;
VAR7:=MA(VAR6,5);
VAR8:=LLV(LOW,5)=LLV(LOW,120);
VAR9:=REF(CLOSE,1);
VARA:=SMA(MAX(CLOSE-VAR9,0),6,1)/SMA(ABS(CLOSE-VAR9),6,1)*100;
VARB:=SMA(MAX(CLOSE-VAR9,0),12,1)/SMA(ABS(CLOSE-VAR9),12,1)*100;
VARC:=(CLOSE+LOW+HIGH)/3;
VARD:=SUM((VARC-REF(LOW,1)-(HIGH-VARC))*VOL/100000/(HIGH-LOW),0);
VARE:=EMA(VARD,1);
VARF:=VARE; VAR10:=MA(VARE,12);
VAR11:=MA(VARE,26); VAR12:=(VARF-VAR10)*60;
VAR13:=IF(VAR12>0.05,VAR12,0);
VAR14:=IF(VAR13>50,50,VAR13);
VAR15:=CAPITAL/EMA(VOL,5)/30*1.1;
VAR16:=VAR15; VAR17:=EMA(COST(85),10);
VAR18:=EMA(COST(1),10);
VAR19:=EMA(CLOSE,10);
VAR1A:=(VAR19-VAR18)*100/(VAR17-VAR18);
VAR1B:=REF(VAR1A,1);
VAR1C:=(CLOSE-REF(CLOSE,12))/REF(CLOSE,12)*100;
VAR1D:=(INDEXC-REF(INDEXC,12))/REF(INDEXC,12)*100;
VAR1E:=EMA(VAR1C-VAR1D,4);
VAR1F:=EMA(VAR1D-VAR1C,4);
STICKLINE(VAR1E>0,0,-5,6,0),COLORBLUE;
STICKLINE(VAR8,-5,-10,6,0),COLORYELLOW;
VAR20:=MA(VAR1C,4);
VAR21:=MA(VAR1C,8);
VAR22:=REF(VAR20,1);
VAR23:=MA((VAR1A-REF(VAR1A,12))/REF(VAR1A,12)*100,4);
VAR24:=IF(VAR23<=-20,-20,VAR23);
VAR25:=IF(VAR24>=20,20,VAR24);
VAR26:=VAR25;
VAR27:=REF(VAR26,1);
VAR28:=REF(VAR26,5);
VAR29:=IF(CROSS(VAR14,VAR16),1,0);
VAR2A:=IF(VAR14<VAR16,-10,10);
VAR2B:=IF(VAR1E>VAR1F,5,-5);
VAR2C:=IF(VAR3>VAR5,5,-5);
VAR2D:=IF(VAR20>VAR21,6,-6);
VAR2E:=IF(VAR20>0 AND VAR20>VAR21,8,-8);
VAR2F:=IF(VAR26<0,-10,10);
VAR30:=IF(VAR20>VAR22,10,-10);
VAR31:=IF(VAR26>VAR27,5,0);
VAR32:=IF(VAR26<VAR27,-5,0);
VAR33:=IF(CLOSE>OPEN,3,-3);
走势:(VAR2A+VAR2B+VAR2C+VAR2D+VAR2E+VAR2F+VAR30+VAR31+VAR32+VAR33);
VAR34:=REF(CLOSE,2)*0.865;
VAR35:=REF(CLOSE,13)*0.772;
VAR36:=MIN(VAR34,VAR35);
VAR37:=100*VOL/CAPITAL;
VAR38:=MA(CLOSE,13);
VAR39:=CLOSE>0.899*REF(CLOSE,1) AND CLOSE<0.901*REF(CLOSE,1);
VAR3A:=EMA(WINNER(CLOSE)*100,5);
VAR3B:=EMA(WINNER(CLOSE)*100,30)-CAPITAL/EMA(VOL,30)/5;
VAR3C:=CAPITAL/EMA(VOL,5)/5;
VAR3D:=VAR3A;
VAR3E:=IF(VAR3D>0,0-VAR3D,0-VAR3D); VAR3F:=REF(VAR3D,1);
主力趋势: (VAR3B+50);
VAR40:=VAR3B+50; VAR41:=REF(VAR40,1); VAR42:=MA(CLOSE,5); VAR43:=MA(CLOSE,10); VAR44:=MA(CLOSE,30);
VAR45:=MA(CLOSE,12);
VAR46:=MA(CLOSE,26); VAR47:=REF(VAR45,1); VAR48:=REF(VAR46,1); VAR49:=(VAR45-VAR46)/VAR45*100; VAR4A:=ABS(VAR45-VAR47)/VAR45*100; VAR4B:=REF(VAR46,1); VAR4C:=REF(VAR4A,1);
VAR4D:=REF(VAR42,1); VAR4E:=REF(VAR43,1); VAR4F:=COUNT(CLOSE>REF(CLOSE,1),5)/5*100; VAR50:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100; VAR51:=SMA(VAR50,5,1);
VAR52:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
VAR53:=SMA(VAR52,2,1);
VAR54:=MA(VOL/CAPITAL,30)*MA(VOL,60)/10000+MA(CLOSE,30)*8;
VAR55:=REF(VAR51,1); VAR56:=REF(VAR53,1);
VAR57:=REF(VAR54,1); VAR58:=MA(VAR53,5);
VAR59:=MA(VAR53,12); VAR5A:=MA(VAR53,26);
VAR5B:=REF(VAR4F,1); VAR5C:=(VAR54-VAR57)/VAR54*100;
VAR5D:=SMA(VAR50,5,1); VAR5E:=REF(VAR5D,1); VAR5F:=SMA(VAR52,2,1);
VAR60:=REF(VAR5F,1); VAR61:=IF(CLOSE>OPEN,1,0);
VAR62:=IF(VAR42>VAR4D,1,0); VAR63:=IF(VAR43>VAR4E,1,0);
VAR64:=IF(VAR4A>VAR4C,1,0); VAR65:=IF(VAR53>VAR56,5,0);
VAR66:=IF(VAR55>VAR51,5,0); VAR67:=IF(VAR54>VAR57,2,0); VAR68:=IF(VAR49>2.25,10,0); VAR69:=IF(VAR53>60,6,0); VAR6A:=IF(VAR53>80,8,0); VAR6B:=IF(VAR53>VAR51,10,0); VAR6C:=IF(VAR53>VAR51,VAR59-VAR5A,0); VAR6D:=IF(VAR53>VAR51 AND VAR51<20,5,0); VAR6E:=IF(CLOSE>VAR45 AND VAR45>VAR46,5,0); VAR6F:=IF(VAR45>VAR46,5,0); VAR70:=IF(VAR46>VAR4B,5,0);
VAR71:=IF(VAR51<18,VAR58-VAR51,0);
VAR72:=IF(VAR51>VAR53 AND VAR51>50,8,0);
VAR73:=(VAR61+VAR62+VAR63+VAR64+VAR65+VAR66+VAR67+VAR68+VAR69+VAR6A+VAR6B+VAR6C+VAR6D+VAR6E+VAR6F+VAR70+VAR71-VAR72);
VAR74:=REF(VAR73,1); 多头: MA(VAR73,5); VAR75:=MA(VAR73,8); VAR76:=MA(VAR73,12); VAR77:=MA(VAR73,26); VAR78:=MA(VAR73,13); VAR79:=REF(VAR76,1); VAR7A:=REF(VAR76,2);
VAR7B:=IF(CROSS(VAR3,VAR5) AND VAR4<35 AND VAR7>50 AND VAR1A<25 AND VAR1A>VAR1B AND VAR41<VAR40 AND (VARA>VARB AND VARB>VAR3 OR VARA>VAR3 AND VAR8),100,0);
VAR7C:=IF((CLOSE-VAR36)/CLOSE<0.1 AND VAR41<VAR40 AND SUM(VAR37,5)/5<1.8,100,0);
VAR7D:=IF(CROSS(VAR3,VAR5) AND VAR8 AND VAR3<25 AND VAR1A<20 OR CROSS(VAR3,VAR5) AND VAR8 AND VAR3<40 AND VAR1A<10,100,0);
信号: IF(VAR7B=100 OR VAR7C=100 OR VAR7D=100,20,-50),COLORYELLOW;
STICKLINE(走势<0,0,走势,1,0),COLORGREEN;
STICKLINE(走势>0,走势,0,1,0),COLORRED;
 
动力线 会用的慢慢研究下
N:=30;M:=13;
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100;
RSIF:=90-RSI1,COLOR33DD33;
A4:=((C-LLV(L,33))/(HHV(H,33)-LLV(L,33)))*67;
VAR22:=LLV(LOW,10);
VAR33:=HHV(HIGH,25);
动力线:EMA((CLOSE-VAR22)/(VAR33-VAR22)*4,4);
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
PP101:=SMA(RSV,3,1);
PP102:=SMA(PP101,3,1);
PP103:=3*PP101-2*PP102;
STICKLINE(动力线>0 AND ISLASTBAR AND ((PP103>PP101 AND PP103<REF(PP103,1)) OR PP103>PP101),20,80,0,1),COLORGRAY;
STICKLINE(动力线>=0.2 AND 动力线<0.5 AND ISLASTBAR AND ((PP103>PP101 AND PP103<REF(PP103,1)) OR PP103>PP101),20,35,2,1),COLORGRAY;{底部保持关注,灰色}
STICKLINE(动力线>=0.5 AND 动力线<1.75 AND ISLASTBAR AND ((PP103>PP101 AND PP103<REF(PP103,1)) OR PP103>PP101),35,50,2,0),COLORYELLOW;{底部酌情买入,黄色}
STICKLINE(动力线>=1.75 AND 动力线<3.2 AND ISLASTBAR AND ((PP103>PP101 AND PP103<REF(PP103,1)) OR PP103>PP101),50,65,2,0),COLORRED;{强势持仓段,红色}
STICKLINE(动力线>=3.2 AND 动力线<3.45 AND ISLASTBAR AND  ((PP103>PP101 AND PP103<REF(PP103,1)) OR PP103>PP101),65,72,2,0),COLORLIRED;{阶段卖出,粉红}
STICKLINE(动力线>=3.45 AND ISLASTBAR,72,80,2,0) AND PP103<PP101,COLORCYAN;{清仓卖出,青色};
STICKLINE(PP103<PP101 AND ISLASTBAR,30,70,1,1),COLORGREEN;{甭看了,快找高人指点或者骂街,好像要大跌,绿色};
{以下显示在上方第二行}
STICKLINE(动力线>0 AND ((PP103>PP101 AND PP103<REF(PP103,1)) OR PP103>PP101),95,94,1,0),COLORGRAY;
STICKLINE(动力线>=0.2 AND 动力线<0.5 AND ((PP103>PP101 AND PP103<REF(PP103,1)) OR PP103>PP101),95,92,3,0),COLORGRAY;{底部保持关注,灰色}
STICKLINE(动力线>=0.5 AND 动力线<1.75 AND ((PP103>PP101 AND PP103<REF(PP103,1)) OR PP103>PP101),95,94,1,0),COLORYELLOW;{底部酌情买入,黄色}
STICKLINE(动力线>=1.75 AND 动力线<3.2 AND ((PP103>PP101 AND PP103<REF(PP103,1)) OR PP103>PP101),95,94,1,0),COLORRED;{强势持仓段,红色}
STICKLINE(动力线>=3.2 AND 动力线<3.45 AND  ((PP103>PP101 AND PP103<REF(PP103,1)) OR PP103>PP101),95,92,3,0),COLORLIRED;{阶段卖出,粉红}
STICKLINE(动力线>=3.45,95,92,3,0) AND PP103<PP101,COLORCYAN;{清仓卖出,青色};
STICKLINE(PP103<PP101,95,94,1,0),COLORGREEN;{甭看了,快找高人指点或者骂街,好像要大跌,绿色};
VAR1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2:=SMA(VAR1,9,1)+100;
VAR3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4:=SMA(VAR3,3,1);
VAR5:=SMA(VAR4,3,1)+100;
VAR6:=VAR5-VAR2;
趋势:IF(VAR6>45,VAR6-45,0);
STICKLINE(REF(趋势,1)< 趋势, 趋势,REF(趋势,1),2,0),COLORMAGENTA;
STICKLINE(REF(趋势,1)> 趋势, 趋势,REF(趋势,1),2,0),COLORGREEN;
强弱分界:=50,COLORFFFFCC;
底部:=0,COLOR00FFFF;
安全:=20,COLORFFAA66,LINETHICK1;
预警:=80,COLORFFAA66,LINETHICK1;
顶部:=100,COLORFFFF33;
V1:=LLV(LOW,10);
V2:=HHV(H,25);
价位线:=EMA((C-V1)/(V2-V1)*4,4);
{DRAWTEXT(CROSS(价位线,0.3),20+4,'●买'),COLORRED;}
DRAWTEXT(CROSS(3.5,价位线),110-4,'●卖'),COLORWHITE;
VAR2Q:=REF(LOW,1);
VAR3Q:=SMA(ABS(LOW-VAR2Q),3,1)/SMA(MAX(LOW-VAR2Q,0),3,1)*100;
VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);
VAR5Q:=LLV(LOW,30);
VAR6Q:=HHV(VAR4Q,30);
VAR7Q:=IF(MA(CLOSE,58),1,0);
VAR8Q:=EMA(IF(LOW<=VAR5Q,(VAR4Q+VAR6Q*2)/2,0),3)/618*VAR7Q;
VAR9Q:=IF(VAR8Q>100,100,VAR8Q);
AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
AA5:=SMA(AA4,13,8);
走势:=CEILING(SMA(AA5,13,8));
AA6:=SMA(AA3,21,8);
卖临界:STICKLINE(走势-AA6>85,103,100,15,1),COLORRED,LINETHICK2;
主力线:3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*
SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK2,COLORBLUE;
超短线:=(((主力线-LLV(主力线,21))/(HHV(主力线,21)-LLV(主力线,21)))*(4))*(25),LINETHICK2,COLORBLUE;
VAR11:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR21:=SMA(ABS(LOW-VAR11),13,1)/SMA(MAX(LOW-VAR11,0),10,1);
VAR31:=EMA(VAR21,10);
VAR41:=LLV(LOW,33);
VAR51:=EMA(IF(LOW<=VAR41,VAR31,0),3);
主力进场:IF(VAR51>REF(VAR51,1),VAR51,0),COLORRED,NODRAW;
STICKLINE(VAR51>REF(VAR51,1),0,VAR51,3,0 ),COLOR000055;
STICKLINE(VAR51>REF(VAR51,1),0,VAR51,2.6,0 ),COLOR000077;
STICKLINE(VAR51>REF(VAR51,1),0,VAR51,2.1,0 ),COLOR000099;
STICKLINE(VAR51>REF(VAR51,1),0,VAR51,1.5,0 ),COLOR0000BB;
STICKLINE(VAR51>REF(VAR51,1),0,VAR51,0.9,0 ),COLOR0000DD;
STICKLINE(VAR51>REF(VAR51,1),0,VAR51,0.3,0 ),COLOR0000FF;
洗盘:IF(VAR51<REF(VAR51,1),VAR51,0),COLORGREEN,NODRAW;
STICKLINE(VAR51<REF(VAR51,1),0,VAR51,3,0),COLOR005500;
STICKLINE(VAR51<REF(VAR51,1),0,VAR51,2.6,0),COLOR007700;
STICKLINE(VAR51<REF(VAR51,1),0,VAR51,2.1,0),COLOR009900;
STICKLINE(VAR51<REF(VAR51,1),0,VAR51,1.5,0),COLOR00BB00;
STICKLINE(VAR51<REF(VAR51,1),0,VAR51,0.9,0),COLOR00DD00;
STICKLINE(VAR51<REF(VAR51,1),0,VAR51,0.3,0),COLOR00FF00;
VAR12:=3;
VAR28:=(3)*(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1)) - (2)*(SMA(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1),3,1));
{股价准备启动:IF(CROSS(VAR28,VAR11),100,0),COLORRED,LINETHICK2;}
SS1:=(LOW+HIGH+CLOSE*2)/4;
SS2:= MA(SS1,4);
SS3:=HHV(SS2,10);
SS4:=MA(SS3,3);
SS5:=1.25*SS4-0.25*SS3;
XKKJ:=IF(SS5>SS3,SS3,SS5);
FF1:=LLV(SS2,10);
FF2:=MA(FF1,3);
FF3:=1.25*FF2-0.25*FF1;
DKKJ:=IF(FF3<FF1,FF1,FF3);
MA13:=MA(C,13);
ZDHM:=CROSS(C,DKKJ) AND CROSS(C,MA13) AND CROSS(C,XKKJ);
ZHM:=CROSS(C,MA13) AND CROSS(C,XKKJ);
大黑马:IF(ZDHM OR ZHM,50,0),COLORYELLOW,LINETHICK3;
动态底部:=EMA(IF(L<= LLV(L,30),SMA(ABS(L-REF(L,1)),30,1)/SMA(MAX(L-REF(L,1),0),99,1),0)*5,3);
准备买入:=CROSS(C,TROUGH(CLOSE,N,1)*1.02);
低点:IF(动态底部 AND 准备买入,50,0),COLORWHITE,LINETHICK3;
RSV11:=(CLOSE-LLV(LOW,19))/(HHV(HIGH,19)-LLV(LOW,19))*100;
K:=SMA(RSV11,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
短线:=EMA(J,6),COLORRED;
浮筹:=MA(短线,28)*1,LINETHICK2,COLORGREEN;
空方:=MA(100*(HHV(HIGH,35)-CLOSE)/(HHV(HIGH,35)-LLV(LOW,35)),3),COLORYELLOW;
DRAWTEXT(CROSS(短线,浮筹) AND 短线<36,20+4,' 买'),COLORLIBLUE;
DRAWICON(CROSS(短线,浮筹) AND 短线<36,20+4,17),COLORBLUE, LINETHICK1;
DRAWTEXT(CROSS(浮筹,空方),浮筹,' 追'),COLORWHITE;
DRAWICON(CROSS(浮筹,空方),浮筹,16);
 
稳赚
QW1:=(HIGH+LOW+CLOSE*2)/4;
QW3:=EMA(QW1,10);
QW4:=STD(QW1,10);
QW5:=(QW1-QW3)*100/QW4;
QW6:=EMA(QW5,5);
RK7:=EMA(QW6,10);
涨:EMA(QW6,10)+100/2-5,LINETHICK1,COLORRED;
跌:EMA(涨,4),LINETHICK1,COLORFFFF34;
多线:IF(CROSS(涨,跌) AND 跌<-10,30,0),LINETHICK1,COLORFF00FF;
空线:IF(CROSS(跌,80),70,100),COLOR0099FF,LINETHICK1;
买1:EMA(跌,4),COLORWHITE;
买2:EMA(买1,4),COLORGREEN;
买M3:=EMA(买2,4),COLORYELLOW;
买M4:=EMA(买M3,4),COLORCC9900;
-10,POINTDOT,COLOR888888,LINETHICK2;
80,POINTDOT,COLOR888888,LINETHICK2;
STICKLINE(涨<REF(涨,1),涨,MA(涨,3),2,0 ),COLOR00EE00;
STICKLINE(涨<REF(涨,1),涨,MA(涨,3),1,0 ),COLOR00FF00;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),3,0) ,COLOR0099FF;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),2,0) ,COLOR00AAFF;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),1,0) ,COLOR00BBFF;
DRAWICON(多线,30,1),COLORFF00FF;
DRAWICON(CROSS(跌,80),70,2),COLORGREEN;
DRAWTEXT(CROSS(涨,跌) AND 跌<20 AND 跌>-10,40,'买入'),COLORCCFF99;
DRAWTEXT(多线>0,-20,'看涨'),COLOR0000FF;
VAR2:=MA(CLOSE,194);
VAR3:=VAR2+2*STD(CLOSE,170);
顶:(CLOSE>VAR3)*13*10,COLORBLUE,LINETHICK2;
VAR18:=HHV(HIGH,30);
VAR19:=LLV(LOW,30);
NL:=EMA((CLOSE-VAR19)/(VAR18-VAR19)*100,5)/8*10,COLORYELLOW,LINETHICK2;
DRAWTEXT(CROSS(5,NL),30,'★做底'),COLORWHITE;
VAR44:=REF(CLOSE,1);
VAR45:=SMA(MAX(CLOSE-VAR44,0),6,1)/SMA(ABS(CLOSE-VAR44),6,1)*100;
STICKLINE(CROSS(84,VAR45),0,VAR2*15+3,3,1),COLORGREEN;
DRAWTEXT(CROSS(84,VAR45),80,'防空警报'),COLORGREEN;

VAR55:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,5);
VAR56:=INDEXC;
VAR57:=MA(VAR56,5);
VAR58:=MA(VAR56,20);
VAR5B:=VAR57>VAR56*1.03 AND VAR58>VAR56*1.13;
VAR5D:=IF(FILTER(VAR55<6,5)=1,1,0);
VAR5F:=VAR55<6 AND VAR5B;

VAR61:=VAR5F AND VAR5D*80;
VAR7C:=IF(EMA(CLOSE,5)/EMA(EMA(CLOSE,9),16)<=0.85 AND CLOSE/REF(CLOSE,1)>0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,50,0);
VAR7D:=(-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))+100;
VAR7E:=(-100)*(HHV(HIGH,50)-CLOSE)/(HHV(HIGH,50)-LLV(LOW,50))+100;
VAR7F:=(-100)*(HHV(HIGH,70)-CLOSE)/(HHV(HIGH,70)-LLV(LOW,70))+100;

VAR80:=((CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100+10)*5;
VAR81:=((CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100+10)*5;
VAR82:=((CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+10)*5;
VAR83:=(VAR7D+VAR7E+VAR7F+VAR80+VAR81+VAR82)/6;
VAR84:=EMA(VAR83,3);
VAR85:=ABS(VAR80-VAR82);
VAR86:=(VAR83+VAR85)/2;
VAR87:=(-1)*(EMA(100*(1-WINNER(CLOSE)),1)-50)+50;
VAR88:=VAR87+VAR86;
VAR89:=IF(VAR7C>0 AND VAR88<0,200,0);
VAR8A:=IF(VAR86<0 AND CLOSE=LLV(CLOSE,5) AND CLOSE/REF(CLOSE,1)>0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,-50,0);
VAR8B:=IF(VAR88<0 AND VAR8A=-50,100,0);

VAR8D:=REF(CLOSE,2)*0.865;
VAR8E:=REF(CLOSE,13)*0.772;
VAR8F:=MIN(VAR8D,VAR8E);
VAR90:=100*VOL/CAPITAL;
VAR92:=IF((CLOSE-VAR8F)/CLOSE<0.03 AND SUM(VAR90,5)/5<1.8,1,0);
VAR96:=(VAR89>0 AND VAR8B>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR VAR92>0) AND (VAR8A<0 OR VAR7C>0);
VAR97:=VAR89>0 AND VAR8B>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR VAR92>0 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902;
VAR98:=VAR96 OR VAR97;

VARA4:=AMOUNT/VOL/100;
VARA5:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VARA7:=SUM(AMOUNT,13)/VARA4/100;
VARAE:=DMA(VARA5,VOL/VARA7);


VARB1:=MA(HHV(HIGH,488),18);
VARB2:=MA(HHV(HIGH,220),18);
VARB3:=MA(HHV(HIGH,98),18);
VARB4:=MA(LLV(LOW,488),18);
VARB5:=MA(LLV(LOW,220),18);
VARB6:=MA(LLV(LOW,98),18);
VARB7:=MA((VARB4*0.96+VARB5*0.96+VARB6*0.96+VARB1*0.558+VARB2*0.558+VARB3*0.558)/6,18);
VARB8:=MA((VARB4*1.25+VARB5*1.23+VARB6*1.2+VARB1*0.55+VARB2*0.55+VARB3*0.65)/6,18);
VARB9:=MA((VARB4*1.3+VARB5*1.3+VARB6*1.3+VARB1*0.68+VARB2*0.68+VARB3*0.68)/6,18);
VARBA:=MA((VARB7*3+VARB8*2+VARB9)/6*1.738,18);
VARBC:=LOW;
VARBD:=REF(LOW,1);
VARBE:=SMA(ABS(VARBC-VARBD),3,1)/SMA(MAX(VARBC-VARBD,0),3,1)*100;
VARBF:=MA(IF(CLOSE*1.35<=VARBA,VARBE*10,VARBE/10),3);
VARC0:=LLV(LOW,30);
VARC1:=HHV(VARBF,30);
VARC2:=IF(LOW<=VARC0,(VARBF+VARC1*2)/2,0);
WXBM:(MA(VARC2 AND CLOSE<COST(1),3) AND (CLOSE-VARAE)/VARAE*100<-11)*118,COLORRED,LINETHICK2;
DRAWTEXT(VAR61 OR VAR98,70,'★大黑马'),COLORYELLOW;

DRAWTEXT(WXBM,100,'BM'),COLORRED;
STICKLINE(VAR61,0,120,3,0),COLORWHITE;
STICKLINE(VAR98,0,90,3,0),COLORYELLOW;
X:=C-REF(MA(C,20),11);
LGL:=IF(EMA(C,5)/EMA(EMA(C,9),16)<=0.85 AND C/REF(C,1)>0.905 AND C/REF(C,1)<1.05 AND VOL/CAPITAL*100<5,50,0);
WR1:=-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))+100*X;
WR2:=-100*(HHV(HIGH,50)-CLOSE)/(HHV(HIGH,50)-LLV(LOW,50))+100;
WR3:=-100*(HHV(HIGH,70)-CLOSE)/(HHV(HIGH,70)-LLV(LOW,70))+100*X;
BIAS1:=((CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100+10)*5;
BIAS2:=((CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100+10)*5;
BIAS3:=((CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+10)*5;
S1:=(WR1+WR2+WR3+BIAS1+BIAS2+BIAS3)/6*X;
S2:=EMA(S1,3);
S3:=ABS(BIAS1-BIAS3);
SX:=(S1+S3)/2;
XC1:=(-1)*(EMA(100*(1-WINNER(CLOSE)),1)-50)+50;
CCC:=XC1+SX;
ZJZ:=IF( LGL>0 AND CCC<0,200,0)*X;
LXL:=IF(SX<0 AND C=LLV(C,5) AND C/REF(C,1)>0.905 AND C/REF(C,1)<1.05 AND VOL/CAPITAL*100<5,-50,0);
JBJ:=IF(CCC<0 AND LXL=-50,100,0)*X;
MA3:= MA(C,3);
C0:=REF(C,2)*0.865;
C1:=REF(C,13)*0.772;
BOT:=MIN(C0,C1);
HSL:=100*VOL/CAPITAL*X;
MA13:=MA(C,13)*X;
CXC:=IF((C-BOT)/C<3/100 AND SUM(HSL,5)/5<1.8,1,0);
VMC:=IF(CXC>0 AND (LXL<0 OR LGL>0),10,0);
满仓:IF((VMC>0),120,0),COLORRED,LINETHICK3;
DRAWTEXT(满仓>0 AND REF(满仓,1)=0,100,'满仓'),COLORRED;
半仓:IF(((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR (CXC>0 AND REF(C,1)/REF(C,2)>0.902)) OR (((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR CXC>0) AND (LXL<0 OR LGL>0)) AND VMC<10 ,100,0),COLORMAGENTA,LINETHICK2;
V93:=(((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR CXC>0) AND (LXL<0 OR LGL>0)) ;
V90:=((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR (CXC>0 AND REF(C,1)/REF(C,2)>0.902));
买11:IF((V93 OR V90),80,0),COLORYELLOW,LINETHICK2;
VAR2Q:=(MA(CLOSE,80)-MA(CLOSE,13)/3);
神奇线:= MA((CLOSE-VAR2Q)/VAR2Q,2);
买12:IF(CROSS(神奇线,0) AND LOW/REF(HIGH,1)<1.012 AND ((C-REF(C,2))/C)>0.06,100,0),COLORMAGENTA,LINETHICK2;
YY:=SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,18,1),12,1);
YT:=SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,12,1);
ST:=IF(CROSS(YT,YY),30,0);
VAR5PT:=(HIGH+LOW+CLOSE)/3;
VAR6PT:=(VAR5PT-MA(VAR5PT,14))/(0.015*AVEDEV(VAR5PT,14));
VAR7PT:=(VAR5PT-MA(VAR5PT,85))/(0.015*AVEDEV(VAR5PT,85));
SA:=IF(VAR7PT>=200 AND VAR6PT>=150,10,0);
VAR3QQ:=REF(CLOSE,1);
VAR4QQ:=SMA(MAX(CLOSE-VAR3QQ,0),6,1)/SMA(ABS(CLOSE-VAR3QQ),6,1)*100;
SM:=IF(CROSS(80,VAR4QQ),100,0);
卖11:IF((SM AND (SA OR ST)),120,0),COLORCCCC33,LINETHICK2;
DRAWTEXT( 卖11>0,110,'卖'),COLORCCCC33;
XX2:=(MA(CLOSE,80)-MA(CLOSE,13)/3);
SQX:=MA((CLOSE-XX2)/XX2,10)*0.01;
买3:IF(CROSS(SQX,0) AND LOW/REF(HIGH,1)<1.012,60,0), STICK,COLORWHITE,LINETHICK2;
稳赚:IF(COUNT(SQX>REF(SQX,1),3)=3 AND COUNT(SQX<0,10)=10 AND REF(SQX,3)=LLV(SQX,10),60,0),COLOR9999FF;
买4: IF(REF(SQX,2)=LLV(SQX,20) AND REF(SQX,2)<0.071 AND REF(SQX,2)<REF(SQX,1) AND NOT(REF(LOW,1)>REF(HIGH,2) AND LOW>REF(HIGH,1)) AND CLOSE>REF(CLOSE,1),60,0),COLORFF00FF,LINETHICK2;
DRAWTEXT( 买3>0,40 ,' 买3'),COLORWHITE;
DRAWTEXT( 稳赚>0,40 ,'稳赚'),COLOR9999FF;
DRAWTEXT( 买4>0,40 , '买4'),COLORFF00FF;
 
A1:=DATE <= 13181231;
工作线:(EMA(C,14)) * A1,POINTDOT,LINETHICK4,COLORYELLOW;

AA05:MA(C,5),LINETHICK3,COLOR0099CC;
五日乖离率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:EMA((速度5-REF(速度5,1)),3),NODRAW;
IF(BB05>30 AND AA05>REF(AA05,1), AA05,DRAWNULL),LINETHICK2,COLORRED;
AA10:MA(C,10), LINETHICK0;
AA20:=MA(C,20);
BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
IF(BB05<0 AND AA05<REF(AA05,1), AA05,DRAWNULL),LINETHICK2,COLORFFFF00;
AA30:MA(C,30), LINETHICK0;
三拾日乖离率:(C-AA30)/AA30*100,NODRAW;
VAR1:=(AA20-AA30)>REF((AA20-AA30),1) AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);
VAR2:=(AA30-AA20)<REF((AA30-AA20),1) AND AA20<REF(AA20,1) AND AA30<REF(AA30,1);
BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;
强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1)  AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1)  ,10) ;
清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>AA30 OR O>AA30) AND AA05<REF(AA05,1)  AND 三拾日乖离率<REF(三拾日乖离率,1) AND AA10<REF(AA10,1),10);
DRAWTEXT(加仓 ,LOW*0.98,'←-----加仓'),COLORYELLOW;
JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND AA10>REF(AA10,1) ;
减仓:=FILTER(JC,10);
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
买入:=FILTER(MR,10);
DRAWTEXT(减仓,HIGH*1.02,'←减仓'),COLORCYAN;
DRAWTEXT(买入,LOW*0.98,'←买入'),COLORYELLOW;

TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));

VAR5:=CROSS(CCI,-100);
VAR6:=CCI>=200;
DRAWTEXT(VAR6,HIGH*1.02,'←----小心'),COLORYELLOW;

SJ:=VAR5;
STICKLINE(SJ,H,L,0.6,0),COLORYELLOW;

LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT(CROSS(84,RSI) , HIGH,'←-----逃'),COLORGREEN;
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.93),'←---大胆搏 '),COLORYELLOW;


A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
生命线:EMA(X,13),LINETHICK2,COLORMAGENTA;
 
攀登图
{N=1,100,27}
盘:=CAPITAL/1000000;
益:=FINANCE(33);
资:=FINANCE(34);
换手:=VOL/CAPITAL;
长阳:=(WINNER(C)-WINNER(O))>=0.15 AND 换手<=0.04;
{缩量长阳:IF(长阳,(WINNER(C)-WINNER(O))*100,0),STICK,COLOR6EA4FF,LINETHICK2;}
VAR1:=(C-REF(C,1))/REF(C,1);
VAR2:=(INDEXC-REF(INDEXC,1))/REF(INDEXC,1);
个股:=EMA(SUM(VAR1,20),5);
大盘:=EMA(SUM(VAR2,20),5);
领涨:=(个股-大盘)>=0;
VAR3:=(C-LLV(L,125))/(HHV(H,125)-LLV(L,125))*100;
VAR4:=SMA(VAR3,72,1);
VAR5:=SMA(VAR4,34,1);
中线趋势:=3*VAR4-2*VAR5;
中线趋势升:=(中线趋势-REF(中线趋势,1))>=0;
均五升:=(MA(C,5)-REF(MA(C,5),1))>=0;
均十升:=(MA(C,10)-REF(MA(C,10),1))>=0;
STICKLINE(均五升 AND 均十升 AND 中线趋势升,0+0.5,0-0.5,6,1),COLORFFFF00,LINETHICK4;
领涨大盘:IF(均五升 AND 均十升 AND 中线趋势升 AND 领涨,4,0),COLORFF99FF;
VAR6:=(2*C+H+L)/4;
VAR7:=LLV(L,N);
VAR8:=HHV(H,N);
攀登:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13)-50;
金山:=EMA(0.618*REF(攀登,1)+0.382*攀登,3);
STICKLINE(攀登>金山 AND 攀登>=REF(攀登,1),攀登+5,金山-1,1.5,0),COLORRED,LINETHICK2;
STICKLINE(攀登>金山 AND 攀登<REF(攀登,1),攀登,攀登,1.5,0),COLORWHITE,LINETHICK2;
STICKLINE(攀登>=金山,金山,金山,1.5,0),COLORYELLOW,LINETHICK2;
STICKLINE(攀登<金山,金山+0.5,金山-0.5,1.5,0),COLORFFFF00,LINETHICK2;
{STICKLINE(领涨大盘=4,攀登+6,金山-1,1.5,0),COLORFF99FF;}
强弱界:0,COLORFFFF00;
STICKLINE(攀登>=金山 AND 均五升 AND 均十升 AND 中线趋势升 ,金山-3,金山-7,2,0),COLOR64A0E6 ;
运动员:=IF(攀登>=金山 AND 均五升 AND 均十升 AND 中线趋势升 AND 金山<0,1,0);
起攀:IF(运动员=1 AND COUNT(运动员=1,5)=1,8,0),COLORFF9999,LINETHICK1;
{DRAWTEXT(起攀=8,金山,'起攀'),COLORWHITE;}
BIAS1:=(C-MA(C,6))/MA(C,6)*100;
BIAS2:=(C-MA(C,12))/MA(C,12)*100;
BIAS3:=(C-MA(C,24))/MA(C,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离:=MA(BIAS,3);
准备:STICKLINE(乖离<-6 AND 乖离>=-12,-6,0,6,1 ),{COLOR33FFCC}COLORYELLOW;
抄底一:IF(乖离<-12 AND 乖离>=-18,-12,0),{COLOR33CCCC}COLORMAGENTA,STICK;
STICKLINE(乖离<-12 AND 乖离>=-18,-12,0,2,0) ,{COLOR33CCCC}COLORMAGENTA;
抄底二:IF(乖离<-18,-18,0),{COLOR3399CC}COLORYELLOW,STICK;
STICKLINE(乖离<-18,-18,0,2,0) ,{COLOR3399CC}COLORYELLOW;
必抄底:IF(起攀=8 AND COUNT(乖离<-12,10)>=1,10,0),LINETHICK0,COLORRED;
STICKLINE(必抄底=10,10,0,10,1),COLORRED;
{DRAWTEXT(必抄底=10,10,'←必抄底'),COLORRED;};
 
波段玄机
{-----------------------☆功能开关------------------------}
DQ_1:=LLV(L,55);  
DQ_2:=HHV(H,55);   
DQ_3:=C-DQ_1;   
DQ_4:=DQ_2-DQ_1;   
DQ_5:=DQ_3/DQ_4;   
DQ_6:=3*SMA(DQ_5*100,7,1)-2*SMA(DQ_5*100,7,1);        
DQ_7:=REF(DMA(DQ_6,2),1);   
DQ_8:=SMA(DQ_6,2,1);  
XY1:=(C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*200*10;
XY2:=SMA(XY1,3,1);      XY3:=LLV(XY2,3);   XY4:=HHV(XY2,3);
ZJ1:=DMA((H+L+C*2)/4,0.9);                 ZJ2:=V/((H-L)*2-ABS(C-O));
ZJ3:=IF(C>O,ZJ2*(H-L),IF(C<O,ZJ2*(H-O+(C-L)),V/2))+IF(C>O,0-ZJ2*(H-C+(O-L)),IF(C<O,0-ZJ2*(H-L),0-V/2));
ZJ4:=ZJ3/20/1.15;                          ZJ5:=ZJ4*0.55+REF(ZJ4,1)*0.33+REF(ZJ4,2)*0.22;    ZJ6:=EMA(ZJ5,3);            
ZJ7:= EMA( ZJ6,13)-EMA( ZJ6,34);           ZJ8:=(ZJ7-EMA(ZJ7,3));                            ZJ9:=IF(ZJ8>=0,1,0);
PH_1:=AMOUNT/(100*V);   PH_2:=MA(PH_1,40); PH_3:=(C-LLV(L,34))/(HHV(H,34)-LLV(L,34))*100;    PH_4:=SMA(SMA(PH_3,3,1),3,1);
PH_5:=SMA(PH_4,5,1)*15,COLORYELLOW;
弱:=XY1<XY3;
吸:=IF(ZJ9 OR (XY1>XY3 OR (XY1>PH_5)),1,0);
空:=XY1<PH_5 AND 吸=0;
强:=XY1>PH_5 AND XY1>XY4;
减:=XY1<XY2 AND XY1>PH_5;
      
{-----------------【图解模板】---------------------}
{DRAWGBK((DATE > 0),COLORRGB(40,40,173),COLORRGB(1,1,14),1);}
弱势:STICKLINE(弱,30,30-PH_3/5,2,1),COLORFF8900;
吸货:STICKLINE(吸,30,30+PH_3/5*0.8,3,1),COLORYELLOW;
强势:STICKLINE(强,30,30+PH_3/5,1,0),COLORRED;
减仓:STICKLINE(减,30,30+PH_3/5,2,0),COLORGRAY;
空仓:STICKLINE(空,30,30+PH_3/5,3,0),LINETHICK3,COLORWHITE;
STICKLINE(DQ_6>=DQ_7,DQ_6,DQ_8,3,0),LINETHICK2,COLORMAGENTA;{主波}
STICKLINE(DQ_6<=DQ_7,DQ_6,DQ_8,3,0),LINETHICK2,COLORWHITE;{主波};



VAR1:=3;
VAR2:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
股价启动在即: IF(CROSS(VAR2,VAR1),70,0);

VARO5:=LLV(LOW,27);
VARO6:=HHV(HIGH,34);
VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25;
{建仓区: IF((VARO7<10),80,100) ,COLOR00CCFF,LINETHICK1;}
0,LINETHICK2 ,COLORFFCC00;

股价趋势: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK0;
底部警戒: 10,COLORRED,LINETHICK0;
买入警戒:STICKLINE(股价趋势<=10,0,20,3,0),COLORYELLOW;
买入信号: STICKLINE(CROSS(股价趋势,底部警戒),0,30,3,0),{COLORFFF666}COLORMAGENTA,LINETHICK2;
顶部警戒: 90,COLORFFBB66,LINETHICK0;
卖出警戒:STICKLINE(股价趋势>=85,80,70,5,0),COLORMAGENTA;
止损出局:STICKLINE(CROSS(顶部警戒,股价趋势),80,60,8,0),COLORFFF666;

{VAR01:=EMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5);
浪花:VAR01,COLORCYAN;};

 
雨青
R1:=EMA(HHV(HIGH,500),21);

R2:=EMA(HHV(HIGH,250),21);

R3:=EMA(HHV(HIGH,90),21);

R4:=EMA(LLV(LOW,500),21);

R5:=EMA(LLV(LOW,250),21);

R6:=EMA(LLV(LOW,90),21);

R7:=EMA((R4*0.96+R5*0.96+R6*0.96+R1*0.558+R2*0.558+R3*0.558)/6,21);

R8:=EMA((R4*1.25+R5*1.23+R6*1.2+R1*0.55+R2*0.55+R3*0.65)/6,21);

R9:=EMA((R4*1.3+R5*1.3+R6*1.3+R1*0.68+R2*0.68+R3*0.68)/6,21);

RA:=EMA((R7*3+R8*2+R9)/6*1.738,21);

RB:=REF(LOW,1);

RC:=SMA(ABS(LOW-RB),3,1)/SMA(MAX(LOW-RB,0),3,1)*100;

RD:=EMA(IF(CLOSE*1.35<=RA,RC*10,RC/10),3);

RE:=LLV(LOW,30);

RF:=HHV(RD,30);

R10:=IF(MA(CLOSE,58),1,0);

主力建仓:EMA(IF(LOW<=RE,(RD+RF*2)/2,0),3)/618*R10/5,COLORSTICK;

V1:=MA(V,5);

V2:=MA(V,10);

W1:=REF(ABS(V1-V2)/V2,1) ;

W9:=W1<0.05 AND REF(C,1)>REF(O,2);

W2:=REF(C,2)>REF(O,3);

W3:=C<O;

W4:=REF(V,2)<REF(V,1);

搭下阳:W9 AND W2 AND W3 AND W4 AND MA(C,10)>REF(MA(C,10),1) AND MA(C,20)>REF(MA(C,20),1);

W5:=ABS(V1-V2)/V2<0.05  AND V2>V1;

W6:=W5 AND C<O;

W7:=REF(W5,1) AND C<O;

W8:=REF(V,1)<V;

上叉阴:W5 AND W6 AND W7 AND W8 AND MA(C,5)<REF(MA(C,5),1) AND MA(C,10)<REF(MA(C,10),1) AND MA(C,20)<REF(MA(C,20),1);

MA5:=MA(C,5);

MA10:=MA(C,10);

MA20:=MA(C,20);

YHD:=COUNT(REF(MA10<MA20,3),16)>=15 AND COUNT(MA5>MA10,3)>2;

小金角:YHD AND CROSS(MA10,MA20)AND MA20>REF(MA20,1);

MA62:=MA(C,62);

V3:=V>REF(V,1);

大金角:CROSS(MA20,MA62)AND MA62>REF(MA62,1) AND COUNT(V3,3)>2;

MA4:=MA(C,4);

L1:=V>REF(V,1);

V4:=COUNT(CROSS(MA10,MA20),15);

V5:=C<REF(CLOSE,1) AND REF(CLOSE,1)<REF(CLOSE,2);

V6:=V4=1 AND V5 AND MA10>C AND C>MA20 AND SLOPE(MA20,4)>0 AND SLOPE(MA10,3)>0;

小金边:REF(V6,2)=1 AND MA4>REF(MA4,1) AND L1;

V7:=V>REF(V,1);

DJJ:=CROSS(MA20,MA62)AND MA62>REF(MA62,1) AND COUNT(V7,3)>2;

大金边:COUNT(DJJ,30)>0 AND C<MA20 AND C>MA62  AND MA62>REF(MA62,1);

DIF:=EMA(CLOSE,12) - EMA(CLOSE,26);

DEA:=EMA(DIF,9);

MACD:=2*(DIF-DEA), COLORSTICK,LINETHICK2;

MACD骑墙: DIF>=0 AND CROSS(DIF,DEA) AND V/MA(V,5)>1.5;

MA60:=MA(C,60);

半山水库:CROSS(MA20,MA60) AND MA60>REF(MA60,1);

A1:=BARSLAST(REF(CROSS(DIF,DEA),1) AND MACD<0);

隔谷底背:REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA) AND MACD>0;

W10:=MA10>REF(MA10,1);

W11:=MA20>=REF(MA20,1);

W12:=V>MA(V,5);

金足底:(MA4<MA20 AND  MA4>=REF(MA4,1) AND C>MA4 AND W10 AND W11 AND W12);

M5:=MA(CLOSE,5);

M4:=MA(CLOSE,4);

MA3:=MA(CLOSE,3);

VOL5:=MA(VOL,5);

雨青抄底:M5>M4 AND SLOPE(M5,5)<0 AND SLOPE(M4,4)<0 AND SLOPE(MA3,3) AND REF(M4>MA3,1) AND CROSS(MA3,M4) AND VOL>VOL5;

VAR1:=SLOPE(MA20,3)>0;

VAR2:=ABS(SLOPE(MA62,3))<0.19;

VAR3:=SLOPE(MA62,3)>REF(SLOPE(MA62,3),1);

V8:=MA62<MA20;

V9:=COUNT(CROSS(MA20,MA62),10);

海豚欲张嘴:C>MA62 AND C<REF(CLOSE,1) AND REF(CLOSE,1)<REF(CLOSE,2) AND VAR1 AND VAR2 AND VAR3 AND V8 AND V9=1;

A4:=MA(C,4);

A20:=MA(C,20);

A62:=MA(C,62);

海豚张嘴1:CROSS(A20,A62)AND A20>REF(A20,1)AND COUNT(A4/A20>1.05,10)>5 AND ABS(A4/A20-1)<0.02 AND V/MA(V,5)>1.5;

AR1:=EMA(CLOSE,12)-EMA(CLOSE,26);

AR2:=EMA(AR1,9);

AR3:=AR1-AR2;

AR4:=MA(CLOSE,4);

AR5:=MA(CLOSE,20);

AR6:=MA(CLOSE,62);

AR7:=LLVBARS(AR4,4);

AR8:=LLVBARS(AR6,30);

AR9:=COUNT(AR7=1,10);

海豚张嘴2:3<AR8<29 AND AR7=1 AND AR4>AR5 AND AR5>AR6 AND AR3>-0.022 AND AR9=1 AND SLOPE(AR6,5)<0.035;

 
彩带函数
STICKLINE(C>=O,C,O,3,0),COLOR000045;
STICKLINE(C>=O,C,O,2.5,0),COLOR000065;
STICKLINE(C>=O,C,O,2,0),COLOR000085;
STICKLINE(C>=O,C,O,1.5,0),COLOR0000A5;
STICKLINE(C>=O,C,O,1,0),COLOR0000C5;
STICKLINE(C>=O,C,O,0.5,0),COLOR0000E5;
STICKLINE(C>=O,H,L,0,0),COLOR0000F5;
STICKLINE(C<O,C,O,3,0),COLOR353500;
STICKLINE(C<O,C,O,2.5,0),COLOR454500;
STICKLINE(C<O,C,O,2,0),COLOR555500;
STICKLINE(C<O,C,O,1.5,0),COLOR656500;
STICKLINE(C<O,C,O,1,0),COLOR757500;
STICKLINE(C<O,C,O,0.5,0),COLOR858500;
STICKLINE(C<O,H,L,0,0),COLOR959500;
AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
DRAWBAND(VAR1,RGB(155,50,50),VAR6,RGB(250,250,0));
短线:VAR1,COLORWHITE;
中线:VAR6,COLORYELLOW;
下跌:IF(VAR1=VAR6,VAR6,DRAWNULL),COLORGREEN;
TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1;
立桩量:=FILTER(TJ1,5);
TJ2:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));
突破:=TJ2=1;
STICKLINE(CLOSE,REF(HIGH,BARSLAST(立桩量)),REF(HIGH,BARSLAST(立桩量)),1,0),COLORCYAN;
STICKLINE(CLOSE,REF(LOW,BARSLAST(立桩量)),REF(LOW,BARSLAST(立桩量)),1,0),COLORYELLOW;
TJ3:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(LOW,3),1,0)));
三天法则:=TJ3=1;
成立:=三天法则 AND 突破;
条件成立:=FILTER(成立,3);
DRAWTEXT(条件成立,L*0.99,'成立'),COLORYELLOW;
 
江恩风火变盘
V1:=BARSCOUNT(CLOSE)*3.142/180;
A2: SIN(V1*8)*100;
A3: COS(V1*8)*100;
X1: 0;
VAR1:=MA(CLOSE,5);
VAR2:=MA(CLOSE,10);
VAR3:=MA(CLOSE,20);
VAR4:=MA(CLOSE,30);
VAR5:=(VAR1+VAR2+VAR3+VAR4)/4;
VAR6:=(VAR5-REF(VAR5,5))/REF(VAR5,5)*1500;
VAR7:=(VAR5-REF(VAR5,5))/REF(VAR5,5)*1500;
VAR8:=EMA(VAR6,8);
底部注意: STICKLINE(VAR6>REF(VAR6,1) AND VAR6<0 AND VAR6<VAR8,VAR6,0,1,0),COLORFF00FF;
低位转强: STICKLINE(VAR8>REF(VAR8,1) AND VAR6<0 AND VAR6>VAR8,VAR8,0,1,0),COLORYELLOW;
买点: STICKLINE(VAR6>REF(VAR6,1) AND VAR6>0 AND VAR8<0,VAR6,VAR8,4,0),COLOR0099FF;
DRAWICON(FILTER(VAR6>REF(VAR6,1) AND VAR6>0 AND VAR8<0,30),-140,4);
DRAWTEXT(FILTER(VAR6>REF(VAR6,1) AND VAR6>0 AND VAR8<0,30),-40,'->买点'),COLORRED;
坚定持股: STICKLINE(VAR8>REF(VAR8,1) AND VAR8>0,VAR6,0,1,0),COLORRED;
谨慎观望: STICKLINE(VAR6<REF(VAR6,1) AND VAR8>REF(VAR8,1) AND VAR6>0,VAR6,VAR8,1,0),COLOR00FF00;
果断持币: STICKLINE(VAR6<REF(VAR6,1) AND VAR6<VAR8,VAR6,VAR8,1,1),COLORFFCC66;

 
主图极品
个股涨跌:((C-REF(C,1))/REF(C,1))*100,NODRAW;
大盘涨跌:((INDEXC-REF(INDEXC,1))/REF(INDEXC,1))*100,NODRAW;A1:EMA((EMA(CLOSE,1)+EMA(CLOSE,3)+EMA(CLOSE,5))/3,3),COLORRED;
A2:EMA((EMA(CLOSE,3)+EMA(CLOSE,5)+EMA( CLOSE,7))/3,3),COLORRED;
A3:EMA((EMA(CLOSE,5)+EMA(CLOSE,7)+EMA( CLOSE,9))/3,3),COLORRED;
A4:EMA((EMA(CLOSE,7)+EMA(CLOSE,9)+EMA( CLOSE,11))/3,3),COLORRED;
A5:EMA((EMA(CLOSE,9)+EMA(CLOSE,11)+EMA( CLOSE,13))/3,3),COLORRED;
A6:EMA((EMA(CLOSE,11)+EMA(CLOSE,13)+EMA( CLOSE,15))/3,3),COLORRED;
A7:EMA((EMA(CLOSE,13)+EMA(CLOSE,15)+EMA( CLOSE,17))/3,3),COLORRED;
A8:EMA((EMA(CLOSE,15)+EMA(CLOSE,17)+EMA( CLOSE,19))/3,3),COLORRED;
A9:EMA((EMA(CLOSE,17)+EMA(CLOSE,19)+EMA( CLOSE,21))/3,3),COLORYELLOW;
A10:EMA((EMA(CLOSE,19)+EMA(CLOSE,21)+EMA( CLOSE,23))/3,3),COLORYELLOW;
A11:EMA((EMA(CLOSE,21)+EMA(CLOSE,23)+EMA( CLOSE,25))/3,3),COLORYELLOW;
A:=EMA((EMA(CLOSE,29)+EMA(CLOSE,31)+EMA(CLOSE,33))/3,3),COLORYELLOW;
B:=REF(A,1);
DRAWTEXT(A>B,(A+B)/2,'★'), COLORFF00FF;
DRAWTEXT(A<=B,(A+B)/2,'☆'), COLORGREEN;
STICKLINE(A>B,A,B,3,0),COLORFF00FF;
STICKLINE(A<=B,A,B,3,1),COLORFF0000;
A15:A-(A1-A*0.997),COLORFF1010;
A16:A-(A2-A),COLORFF2010;
A17:A-(A3-A),COLORFF3010;
A18:A-(A4-A),COLORFF4010;
A19:A-(A5-A),COLORFF5010;
A20:A-(A6-A),COLORFF6010;
A21:A-(A7-A),COLORFF7010;
A22:A-(A8-A),COLORFF8010;
A23:A-(A9-A),COLORFF9010;
A24:A-(A10-A),COLORFFC010;
A25:A-(A11-A*0.997),COLORFFE010;
STICKLINE(OPEN>=CLOSE ,O,C,3,0 ),COLORAAAAAA;
STICKLINE(OPEN>=CLOSE ,O,C,2,0 ),COLORBBBBBB;
STICKLINE(OPEN>=CLOSE ,O,C,1.4,0 ),COLORCCCCCC;
STICKLINE(OPEN>=CLOSE ,O,C,0.5,0 ),COLORDDDDDD;
STICKLINE(CLOSE>OPEN,O,C,3,0 ),COLOR6666CC;
STICKLINE(CLOSE>OPEN,O,C,2 ,0 ),COLOR7777DD;
STICKLINE(CLOSE>OPEN,O,C,1.5 ,0 ),COLOR8888EE;
STICKLINE(CLOSE>OPEN,O,C,1 ,0 ),COLOR9999FF;
STICKLINE(CLOSE>OPEN,OPEN,LOW,0,0 ),COLOR1199FF;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0,0 ),COLOR1199FF;
STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0 ,0 ),COLORCCCCCC;
STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0 ,0 ),COLORCCCCCC;
 
飞机跑道
JJ:=(H+L+3*C)/5;
STICKLINE(JJ>0.05,JJ,JJ,9,0),COLORGREEN;{全天的成交重心}
VAR1:=EMA(JJ,5);VAR2:=EMA(JJ,13);VAR3:=EMA(JJ,21);VAR4:=EMA(JJ,34);
H1A:=(VAR1+VAR2+VAR3+VAR4)/4;
MA(H1A,5),COLORYELLOW;
MA(H1A,6),COLOR3300FF;
MA(H1A,7),COLOR3322FF;
MA(H1A,8),COLOR3344FF;
MA(H1A,9),COLOR3366FF;
MA(H1A,10),COLOR3388FF;
MA(H1A,11),COLOR33AAFF;
MA(H1A,13),COLOR00CCFF,POINTDOT,LINETHICK2;
MA(H1A,15),COLOR33BBFF;
MA(H1A,16),COLOR3399FF;
MA(H1A,17),COLOR3377FF;
MA(H1A,18),COLOR3355FF;
MA(H1A,19),COLOR3333FF;
MA(H1A,20),COLOR3311FF;
MA(H1A,21),COLORGREEN,LINETHICK2;

 
天狼剑
B1:=MA(C,1);
B2:=SMA(SMA(SMA(B1,2,1),2,1),2,1);
SMA2:=MA(B2,3);
停损下限:IF(LLV(MA(B2,8),3)<B2,LLV(MA(B2,8),3),B2);
IF(B2>SMA2,B2,DRAWNULL),COLORRED,LINETHICK4;
IF(B2<SMA2,B2,DRAWNULL),COLORGREEN,LINETHICK4;
SNAKEA:HHV(MA(B2,1),13),COLORYELLOW;
VAR1A:=(2*CLOSE+HIGH+LOW)/4;
VAR2A:=MA(VAR1A,7);
VAR3A:=VAR2A-MA(VAR1A,7/2)<0;
VAR4A:=VAR2A-MA(VAR1A,7/2)>0;
VAR5A:=BARSLAST(VAR3A);
VAR6A:=0-BARSLAST(VAR4A);
VAR7A:=IF(VAR3A<=0,VAR5A,VAR6A);
STICKLINE(SNAKEA>B2 AND B2>SMA2,SNAKEA,B2,0,0),COLORBLUE;
STICKLINE(SNAKEA>SMA2 AND B2<SMA2,SNAKEA,SMA2,0,0),COLORBLUE;
VAR11A:=(CLOSE*2+HIGH+LOW)/4;
VAR21A:=EMA(VAR11A,13)-EMA(VAR11A,34);
VAR31A:=EMA(VAR21A,5);
{STICKLINE((C>=O),OPEN,LOW,0,0),COLOR0726CA;
STICKLINE((C>=O),CLOSE,HIGH,0,0),COLOR0726CA;
STICKLINE((C<O),CLOSE,LOW,0,0),COLORDE9100;
STICKLINE((C<O),OPEN,HIGH,0,0),COLORDE9100;
STICKLINE((C<O),CLOSE,OPEN,2.5,0),COLORFFCC00;
STICKLINE((C<O),CLOSE,OPEN,1.5,0),COLORFFFF00;
STICKLINE((C>O),CLOSE,OPEN,2,0),COLOR0754E9;
STICKLINE((C>O),CLOSE,OPEN,1.5,0),COLOR076EF3;
STICKLINE((C>O),CLOSE,OPEN,1,0),COLOR077BF3;}
VAR2:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
VAR3:=((REF(VAR2,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR4:=((REF(VAR3,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR5:=((REF(VAR4,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR6:=((REF(VAR5,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR7:=((REF(VAR6,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR8:=((REF(VAR7,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR9:=((REF(VAR8,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARA:=((REF(VAR9,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARB:=((REF(VARA,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARC:=((REF(VARB,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARD:=((REF(VARC,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARE:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2)));
VARF:=((REF(VARE,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR10:=((REF(VARF,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR11:=((REF(VAR10,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR12:=((REF(VAR11,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR13:=((REF(VAR12,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR14:=((REF(VAR13,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR15:=((REF(VAR14,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR16:=((REF(VAR15,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR17:=((REF(VAR16,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR18:=((REF(VAR17,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR19:=((REF(VAR18,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR1B:=(REF((((((((((((VARE OR VARF) OR VAR10) OR VAR11) OR VAR12) OR VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18) OR VAR19),1) AND VAR2);

{STICKLINE(VAR1B,O,O+(C-O)/3,3,0),COLOR10D0FF;}
STICKLINE(VAR1B,O,O+(C-O)/3,2,0),COLOR10FFFF;
STICKLINE(VAR1B,O,O+(C-O)/3,1,0),COLOR00FFFF;
AA:=(REF((((((((((((VAR2 OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC) OR VARD),1) AND VARE);



{STICKLINE(AA,O,O+(C-O)/3,3,0),COLOR00DD00;}
STICKLINE(AA,O,O+(C-O)/3,2,0),COLOR00EE00;
STICKLINE(AA,O,O+(C-O)/3,1,0),COLOR00FF00;


A13:=EMA(CLOSE,55);
A14:=MA(CLOSE,75);
A15:=EMA(A14,3);
A16:=EMA(A15,3);
A17:=(HIGH + LOW) / 5;
A18:=(MA(A17,4)) - (MA(A17,34));
A19:=CROSS(A18,0);
A20:=CROSS(0,A18);
A21:=BARSLAST(A19);
A22:=BARSLAST(A20);
A23:=REF(A19,1);
A24:=REF(A20,1);
A25:=BARSLAST(A23);
A26:=BARSLAST(A24);
A27:=IF((A25 < A26),(REF((HHV(HIGH,2)),A25)),(REF((LLV(LOW,2)),A26)));
A28:=(((REF(CLOSE,1)) <= (REF(A27,1))) AND (CLOSE > A27)) AND (A21 < A22);
A29:=(((REF(CLOSE,1)) >= (REF(A27,1))) AND (CLOSE < A27)) AND (A22 < A21);
A30:=A28 AND ((COUNT(A28,A21)) = 1);
A31:=A29 AND ((COUNT(A29,A22)) = 1);
A32:=A30 AND ((REF(BARSLAST(A31),1)) < (REF(BARSLAST(A30),1)));
A33:=A31 AND ((REF(BARSLAST(A31),1)) > (REF(BARSLAST(A30),1)));
DRAWTEXT(A32,SMA2*0.99,'←═≒∝'),COLORYELLOW;
AC:=AMOUNT/(VOL);
YY:=MA(AC,13);
LLL:=(C-YY)/YY*100;
MIDC :=  MA(CLOSE,22);
UPPERC:= MIDC + 2*STD(C,22);
LOWERC:= MIDC - 2*STD(C,22);
BBA:=(C-LOWERC)/(UPPERC-LOWERC);
BBC:=FORCAST(BBA,3);
LIFENGCYC:=(REF(LLL,1)<-15 AND REF(BBA,1)<0 AND LLL>REF(LLL,1));
{//STICKLINE(LIFENGCYC,BBC,0.5,6,0);}
{//BBD:(UPPER+LOWER)/2*(C-UPPER);}

STICKLINE(LIFENGCYC>0,C,O,2,0),COLOR10ABFF;
{STICKLINE(LIFENGCYC>0,C,O,1.5,0),COLOR10D0FF;
STICKLINE(LIFENGCYC>0,C,O,1,0),COLOR10FFFF;}
DRAWTEXT(LIFENGCYC>0,LOW*0.99,'☆'),COLORDD00DD;

 
顾王
{BN:1,100,3;牛:1,100,3;短线:1,20,9;中线:1,30,9;}
MAXCYC:DMA((C+O)/2,V/CAPITAL);
MAV:=(((CLOSE)*(2)+HIGH+LOW)/(4))*(10);
SK:=EMA(MAV,13)-EMA(MAV,34);
SD:=EMA(SK,5);
B:=((2)*(SK-SD))*(5.5);
拉升资金:IF((IF((B>=0),B,(-18))>120),120,IF((B>=0) AND (DATE<=1080531),B,(-18))),LINETHICK2,COLORFF00FF;
VAR96:=((CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28)))*(100);
VAR97:=SMA(VAR96,4,1);
VAR98:=SMA(VAR97,2,1);
VAR99:=DMA(((AMOUNT)/(VOL))/(100),(VOL)/(CAPITAL));
VAR100:=LOW;
VAR101:=REF(LOW,1);
VAR102:=((SMA(ABS(VAR100-VAR101),3,1))/(SMA(MAX(VAR100-VAR101,0),牛,1)))*(100);
VAR103:=MA(IF(((CLOSE)*(1.68)<=MAXCYC),(VAR102)*(10),(VAR102)/(10)),牛);
VAR104:=LLV(LOW,30);
VAR105:=HHV(VAR103,30);
魔王:=MA(IF((LOW<=VAR104),(VAR103+(VAR105)*(2))/(2),0),牛);
牛魔王:IF(魔王>10000,100,0),LINETHICK2,COLOR00FFFF;
VAR106:=MA(CLOSE,5);
VAR107:=MA(CLOSE,10);
VAR108:=MA(CLOSE,30);
VAR109:=(SUM(((CLOSE)*(VOL))*(100),4))/(SUM((VOL)*(100),4));
VAR110:=(SUM(((CLOSE)*(VOL))*(100),7))/(SUM((VOL)*(100),7));
VAR111:=(SUM(((CLOSE)*(VOL))*(100),28))/(SUM((VOL)*(100),28));
VAR112:=(INTPART((VAR111)*(100)))/(100);
短线趋势:=EMA(CLOSE,5)-EMA(CLOSE,10);
中线趋势:=EMA(短线趋势,中线);
VAR113:=REF(中线趋势,1);
VAR114:=中线趋势;
VAR115:=VAR114-VAR113;
VAR116:=REF(短线趋势,1);
VAR119:=短线趋势;
VAR120:=VAR119-VAR116;
VAR117:=OPEN;
VAR118:=CLOSE;
小牛魔王:IF((VAR117<=VAR106) AND (VAR117<=VAR107) AND (VAR117<=VAR108) AND (VAR118>=VAR106) AND (VAR118>=VAR112) AND (VAR115>0) AND (VAR120>0) ,80,0),LINETHICK2,COLORFFFFFF;
主力建仓:IF((VAR98<8.5) AND (VAR97<11),120,(-18)),LINETHICK2,COLOR0000FF;
VAR84:=((CLOSE-MA(CLOSE,13))/(MA(CLOSE,13)))*(100);
VAR85:=100-ABS(VAR84);
VAR86:=(3)*(SMA(((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1))-(2)*(SMA(SMA(((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1),15,1));
VAR87:=(3)*(SMA(((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1))-(2)*(SMA(SMA(((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1),15,1));
VAR88:=100-VAR87;
VAR89:=100-VAR86;
VAR92:=MA(((100)*(CLOSE-LLV(CLOSE,34)))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR93:=100-(3)*(SMA(((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1))+(2)*(SMA(SMA(((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1),15,1));
VAR94:=100-(3)*(SMA(((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1))+(2)*(SMA(SMA(((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1),15,1));
VAR95:=(VAR93<REF(VAR94,1)) AND (VOL>REF(VOL,1)) AND (CLOSE>REF(CLOSE,1));
A11:=(3)*(SMA(((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55)))*(100),5,1))-(2)*(SMA(((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55)))*(100),5,1));
黑马线:=EMA(A11,5);
A12:=((黑马线-REF(黑马线,1))/(REF(黑马线,1)))*(100);
A4:=((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21)))*(100);
趋势线3:=MA((3)*(SMA(A4,6,1))-(2)*(SMA(SMA(A4,5,1),5,1)),2);
N:=3;
VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/(4),1);
VAR2:=(SMA(ABS(LOW-VAR1),13,1))/(SMA(MAX(LOW-VAR1,0),10,1));
VAR3:=EMA(VAR2,10);
VAR4:=LLV(LOW,33);
VAR5:=EMA(IF((LOW<=VAR4),VAR3,0),5);
VAR6:=REF(CLOSE,1);
VAR7:=((SMA(MAX(CLOSE-VAR6,0),6,1))/(SMA(ABS(CLOSE-VAR6),6,1)))*(100);
VAR8:=(LLV(LOW,5)=LLV(LOW,45)) AND (CLOSE>=(OPEN)*(1.04));
VAR9:=(CLOSE>(REF(HIGH,1)+REF(LOW,1))/(2));
VAR10:=VAR8 AND VAR9;
VAR11:=((2)*(CLOSE)+HIGH+LOW)/(4);
VAR12:=LLV(LOW,13);
VAR13:=HHV(HIGH,13);
VAR14:=(LLV(LOW,1)=LLV(LOW,35)) AND (CLOSE>=(OPEN)*(1.04));
VAR15:=(CLOSE>(REF(HIGH,1)+REF(LOW,1))/(2));
VAR16:=EMA(((VAR11-VAR12)/(VAR13-VAR12))*(100),13);
VAR17:=(((CLOSE-MA(CLOSE,6))/(MA(CLOSE,6)))*(100)+((CLOSE-MA(CLOSE,24))/(MA(CLOSE,24)))*(100)+((CLOSE-MA(CLOSE,32))/(MA(CLOSE,32)))*(100))/(3);
VAR19:=MA(CLOSE,13);
VAR20:=100-ABS(((CLOSE-VAR19)/(VAR19))*(100));
VAR21:=LLV(LOW,75);
VAR22:=HHV(HIGH,75);
VAR23:=(VAR22-VAR21)/(100);
VAR24:=SMA((CLOSE-VAR21)/(VAR23),20,1);
VAR25:=SMA((OPEN-VAR21)/(VAR23),20,1);
VAR26:=(3)*(VAR24)-(2)*(SMA(VAR24,15,1));
VAR27:=MA(HHV(HIGH,485),17);
VAR28:=MA(HHV(HIGH,222),17);
VAR29:=MA(HHV(HIGH,96),17);
VAR30:=MA(LLV(LOW,485),17);
VAR31:=MA(LLV(LOW,222),17);
VAR32:=MA(LLV(LOW,96),17);
VAR33:=MA(((VAR30)*(0.96)+(VAR31)*(0.96)+(VAR32)*(0.96)+(VAR27)*(0.558)+(VAR28)*(0.558)+(VAR29)*(0.558))/(6),17);
VAR34:=MA(((VAR30)*(1.25)+(VAR31)*(1.23)+(VAR32)*(1.2)+(VAR27)*(0.55)+(VAR28)*(0.55)+(VAR29)*(0.65))/(6),17);
VAR35:=MA(((VAR30)*(1.3)+(VAR31)*(1.3)+(VAR32)*(1.3)+(VAR27)*(0.68)+(VAR28)*(0.68)+(VAR29)*(0.68))/(6),17);
VAR36:=LLV(LOW,30);
VAR37:=MA((((VAR33)*(3)+(VAR34)*(2)+VAR35)/(6))*(1.738),17);
VAR38:=VAR37;
VAR39:=LOW;
VAR40:=REF(LOW,1);
VAR41:=((SMA(ABS(VAR39-VAR40),3,1))/(SMA(MAX(VAR39-VAR40,0),N,1)))*(100);
VAR42:=MA(IF(((CLOSE)*(1.35)<=VAR38),(VAR41)*(10),(VAR41)/(10)),N);
VAR43:=HHV(VAR42,30);
VAR44:=1080531;
VAR45:=(3)*(VAR25)-(2)*(SMA(VAR25,15,1));
VAR46:=100-VAR45;
VAR47:=1;
VAR49:=(REF(LOW,1))*(0.9);
VAR50:=(LOW)*(0.9);
VAR51:=((VAR50)*(VOL)+(VAR49)*(CAPITAL-VOL))/(CAPITAL);
VAR52:=EMA(VAR51,30);
VAR53:=CLOSE-REF(CLOSE,1);
VAR54:=MAX(VAR53,0);
VAR55:=ABS(VAR53);
VAR56:=((SMA(VAR54,7,1))/(SMA(VAR55,7,1)))*(100);
VAR57:=((SMA(VAR54,13,1))/(SMA(VAR55,13,1)))*(100);
VAR58:=BARSCOUNT(CLOSE);
VAR59:=((SMA(MAX(VAR53,0),6,1))/(SMA(ABS(VAR53),6,1)))*(100);
VAR60:=(((-200))*(HHV(HIGH,60)-CLOSE))/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR61:=((CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15)))*(100);
VAR62:=SMA((SMA(VAR61,4,1)-50)*(2),3,1);
VAR63:=((INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14)))*(100);
VAR64:=SMA(VAR63,4,1);
VAR65:=SMA(VAR64,3,1);
VAR66:=((HHV(HIGH,30)-CLOSE)/(CLOSE))*(100);
VAR67:=(VAR59<=25) AND (VAR60<(-95)) AND (VAR66>20) AND (VAR62<(-30)) AND (VAR65<30) AND (VAR52-CLOSE>=(-0.25)) AND (VAR56<22) AND (VAR57<28) AND (VAR58>50);
VAR68:=(HIGH+LOW+CLOSE)/(3);
VAR69:=(VAR68-MA(VAR68,14))/((0.015)*(AVEDEV(VAR68,14)));
VAR70:=(VAR68-MA(VAR68,70))/((0.015)*(AVEDEV(VAR68,70)));
VAR71:=IF((VAR69>=150) AND (VAR69<200) AND (VAR70>=150) AND (VAR70<200),10,0);
VAR72:=IF((VAR69<=(-150)) AND (VAR69>(-200)) AND (VAR70<=(-150)) AND (VAR70>(-200)),(-10),VAR71);
VAR73:=((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100);
VAR74:=REVERSE(VAR73);
VAR75:=SMA(VAR73,3,1);
绝佳买点:=MA(IF((LOW<=VAR36),(VAR42+(VAR43)*(2))/(2),0),N);
跑:=FILTER((REF(黑马线,1)>90) AND (A12<0) ,7);
买线:=EMA(CLOSE,2);
卖线:=EMA((SLOPE(CLOSE,21))*(20)+CLOSE,42);
指數位置:=(3)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1))-(2)*(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1));
抄底:=CROSS(指數位置,10);
A1:=(VOL=HHV(VOL,120));
A2:=((CLOSE)/(OPEN)>1.05);
TJ:=A1 AND A2;
龙:=VAR10;
买4:=VAR14;
AA1:=(AMOUNT)/(VOL);
BB1:=(LOW<(AA1)*(0.9));
CC1:=(((CLOSE-REF(CLOSE,1))/(REF(CLOSE,1)))*(100)>1.2);
DD1:=(LOW<(MA(CLOSE,5))*(0.921));
EE1:=(VOL<(MA(VOL,5))*(1.5));
FF1:=BB1 AND CC1 AND DD1 AND EE1;
买3:=FILTER(FF1,3);
二十天最低跌幅:=(HHV(CLOSE,20))/(LLV(CLOSE,20));
RSV:=((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9)))*(100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=(3)*(K)-(2)*(D);
X:=(LLV(J,2)=LLV(J,8));
买1:=CROSS(J,REF(J+0.01,1)) AND X AND (J<20) AND (二十天最低跌幅>=1.3);
长期底部:=LLV(HIGH,30);
上:=(SMA(LOW,5,2))*(0.96);
短期底部:=(LLV(HIGH,30))*(0.93);
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX(CLOSE-LC,0),6,1))/(SMA(ABS(CLOSE-LC),6,1)))*(100);
大顶:=FILTER((VAR17>20) AND FILTER((VAR17<REF(VAR17,1)),5),5);
VAR76:=(OPEN+LOW+HIGH+CLOSE)/(4);
MAN:=(SMA(HIGH,21,2))*(1.05);
短底2:=EMA(VAR76,5);
支撑:=HHV(短底2,60);
VAR77:=((HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36)))*(100);
VAR78:=SMA(VAR77,5,1);
VAR79:=SMA(VAR78,8,1);
VAR80:=CROSS(VAR78,VAR79) AND (VAR79<5);
VAR81:=(CLOSE>LLV(CLOSE,60)+(0.3)*(LLV(CLOSE,60))) AND VAR80;
VAR82:=IF((CLOSE>1000),VAR80,VAR81);
黑马起步:=VAR82;
逃:=FILTER((HIGH>支撑) AND (CLOSE<支撑) AND ((CLOSE)/(OPEN)>0-1.06) AND (CLOSE<OPEN),5);
逃命:=(黑马起步>0);
选逃:=FILTER((((逃命 OR 逃) OR CROSS(84,RSI)) OR 大顶),3) ;
WW:=1;
散户:=((SMA(VAR75,3,1))*(VAR47))*(WW);
新庄:=((SMA(散户,3,1))*(VAR47))*(WW);
高抛:=CROSS(新庄,散户) AND (新庄>75);
买:CROSS(买线,卖线) ,COLOR0000FF;
卖:CROSS(卖线,买线) ,COLOR008000;
大黑马:=CROSS(趋势线3,0) AND (黑马线<40);
大买:=FILTER((绝佳买点>30000),5);
大资金进场:=VAR95 AND (COUNT(VAR95,30)=1);
做空:=高抛+选逃+(卖=1)+跑;
选拉升股:=(买 AND (拉升资金>0) OR (拉升资金>0) AND (COUNT(买,5)>=1) AND (COUNT(做空,BARSLAST(买))=0) AND (REF((拉升资金>0) AND (COUNT(买,5)>=1) AND (COUNT(做空,BARSLAST(买))=0),1)=0));
选潜力股:=(COUNT(做空,BARSLAST(买))=0) AND ((CLOSE)/(REF(CLOSE,BARSLAST(买)))<=1.08) AND ((主力建仓=120) OR (拉升资金>0)) ;
选暴涨股:买 AND ((COUNT((主力建仓=120),BARSLAST(做空))>=3) OR (COUNT(大黑马+大买+大资金进场,7)>=1)),COLORFF0000;
选暴涨潜力:((CLOSE)/(REF(CLOSE,BARSLAST(选暴涨股)))<=1.1) AND (COUNT(做空,BARSLAST(选暴涨股))=0),COLOR000080;
选超级暴涨股:(选暴涨股 AND (COUNT((主力建仓=120),10)>=3) OR 买 AND (COUNT(大黑马+大买+大资金进场,7)>=1) AND (COUNT(做空,BARSLAST(((大黑马 OR 大买) OR 大资金进场)))=0)),COLOR800080;
黄金暴涨股:买 AND (COUNT((主力建仓=120),BARSLAST(做空))>=3) AND (拉升资金>0) AND (COUNT(大黑马+大买+大资金进场,7)>=1) AND (COUNT(做空,BARSLAST(((大黑马 OR 大买) OR 大资金进场)))=0),COLOR00FFFF;
坚决买进:(((买 AND 选暴涨潜力 OR 选暴涨股) OR 选超级暴涨股) OR 黄金暴涨股),COLORFF00FF;
坚决买进潜力股:(坚决买进 OR ((CLOSE)/(REF(CLOSE,BARSLAST(坚决买进)))<=1.1) AND (COUNT(做空,BARSLAST(坚决买进))<=1)) AND (COUNT(做空,BARSLAST(买))=0) AND (做空=0),COLOR00FF00;
黄金暴涨潜力股:(黄金暴涨股 OR ((CLOSE)/(REF(CLOSE,BARSLAST(黄金暴涨股)))<=1.1) AND (COUNT(做空,BARSLAST(黄金暴涨股))=0)) AND (COUNT(做空,BARSLAST(买))=0) AND (做空=0),COLORFFFFFF;
选底:FILTER((LOW<=上) AND (HIGH>=短期底部) AND (CLOSE>=长期底部) AND ((CLOSE)/(OPEN)>1.03),3) AND (DATE<=1080531),COLORFFFF00;
稳赚10买:FILTER((买3 OR 选底),3) AND (COUNT(买1+买4+龙,3)>0),COLOR0000FF;
选持股阶段股:(COUNT(卖,BARSLAST(买))=0),COLOR008000;
STICKLINE(黄金暴涨潜力股,50,40,7,0),COLORFF0000;

STICKLINE((买=1),0,50,7,0),COLOR1020FF;

STICKLINE((卖=1),50,100,7,0),COLORFFDD00;
STICKLINE(VAR95 AND (COUNT(VAR95,30)=1),50,85,5,0),COLORFF0000;
STICKLINE(大黑马,50,90,5,0),COLORFF0000;
STICKLINE(大买,50,30,3,0),COLOR0000FF;
STICKLINE(选逃,50,65,3,0),COLORFF0000;
STICKLINE((选底=1),50,80,3,0),COLOR399C71;
STICKLINE((稳赚10买=1),50,65,3,0),COLORFF0000;
STICKLINE(高抛,50,75,3,0),COLORFF0000;
STICKLINE(跑,50,65,3,0),COLORFF0000;
STICKLINE(坚决买进潜力股,50,58,6,0),COLORFF0000;
STICKLINE(选持股阶段股,70,50,0.1,0),COLOR0000FF;
DRAWTEXT(选持股阶段股,75,'—'),COLOR0000FF;
DRAWTEXT(坚决买进,13,'坚决买'),COLOR00FFFF;
DRAWTEXT(选拉升股,40,'▲'),COLOR00FFFF;
DRAWTEXT(选暴涨股,50,'★'),COLOR00FFFF;
DRAWTEXT(选超级暴涨股,60,'●'),COLOR00FFFF;
DRAWTEXT(黄金暴涨股,73,'■'),COLOR00FFFF;
DRAWTEXT(VAR95 AND (COUNT(VAR95,30)=1),110,'大资金'),COLORFFFFFF;
DRAWTEXT(VAR95 AND (COUNT(VAR95,30)=1),100,'进场'),COLORFFFFFF;
DRAWTEXT(跑,70,'跑'),COLORYELLOW;
DRAWTEXT(大黑马,105,'大黑马'),COLORFFFFFF;
DRAWTEXT(CROSS(新庄,散户) AND (新庄>75),90,'抛'),COLOR008000;
DRAWTEXT((稳赚10买=1),80,'赚10'),COLORFFFFFF;
DRAWTEXT((稳赚10买=1),67,'%买'),COLORFFFFFF;
DRAWTEXT(IF((选底=1),100,0),92,'底'),COLORFFFFFF;
DRAWTEXT(选逃,80,'逃'),COLOR008000;
DRAWTEXT(大买,30,'大买'),COLORFFFFFF;
DRAWTEXT((买=1),(-2),'买'),COLOR0000FF;
DRAWTEXT((卖=1),117,'卖'),COLOR00FFFF;
 
资金均线
流通:=(AMOUNT / VOL);
VAR1:=(C-REF(C,1))*流通;
LLJX:=SMA(VAR1 ,9 , 1);
资金流量:=LLJX,LINETHICK0;
MA5:MA(LLJX,5),LINETHICK2;
MA20:MA(资金流量,20),LINETHICK2;
MA40 :MA(资金流量,40),LINETHICK2;
MA60:MA(资金流量,60),LINETHICK2;
BOLL:=MA(MA5,20);
UPPER:BOLL+2*STD(MA5,20),COLORYELLOW;
LOWER:BOLL-2*STD(MA5,20),COLORYELLOW;
STICKLINE( MA5>=REF(MA5,1),MA5,REF(MA5,1),5,0),COLORRED;
STICKLINE(MA5<REF(MA5,1) , MA5 ,REF(MA5,1) ,5 , 1),COLORGREEN;
STICKLINE(MA20>=REF(MA20,1),MA20 ,REF(MA20,1) ,5 , 0),COLORFF00FF;
STICKLINE(MA20<REF(MA20,1)  ,MA20 ,REF(MA20,1) ,5, 0),COLORGREEN;
STICKLINE( MA40>=REF(MA40,1),MA40,REF(MA40,1),5,1),COLORYELLOW;
STICKLINE(MA40<REF(MA40,1) , MA40 ,REF(MA40,1) ,5 , 1),COLORWHITE;
STICKLINE(MA60>=REF(MA60,1),MA60 ,REF(MA60,1) ,5 , 1),COLORFF00FF;
STICKLINE(MA60<REF(MA60,1)  ,MA60 ,REF(MA60,1) ,5, 1),COLORCYAN;
DRAWTEXT(ISLASTBAR,MA5,'----5'),COLORYELLOW;  
DRAWTEXT(ISLASTBAR,MA20,'-----20'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,MA40,'--------40'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,MA60,'-----------60'),COLORYELLOW;
 
 
趋势射线
趋势射线3X: DRAWLINE(L=LLV(L,3),L,C=HHV(C,3),L,0),COLOR9A90FF;
趋势射线7: DRAWLINE(H=HHV(H,7),H,L=LLV(L,7),L,0),COLOR9AFF89;
射线7X: DRAWLINE(L=LLV(L,7),L,H=HHV(H,7),L,0),COLOR9AFF89;
趋势射线21: DRAWLINE(H=HHV(H,21),H,L=LLV(L,21),L,0),COLORC100FF;
射线21X: DRAWLINE(L=LLV(L,21),L,H=HHV(H,21),L,0),COLORC100FF;
趋势射线35: DRAWLINE(H=HHV(H,35),H,L=LLV(L,35),L,0),COLORC1005B;
射线35X: DRAWLINE(L=LLV(L,35),L,H=HHV(H,35),L,0),COLORC1005B;
趋势射线49: DRAWLINE(H=HHV(H,49),H,L=LLV(L,49),L,0),COLORYELLOW;
射线49X: DRAWLINE(L=LLV(L,49),L,H=HHV(H,49),L,0),COLORYELLOW;

 
 
攻防六线
估:=(2*CLOSE+LOW+HIGH)/4;
界:=SLOPE(CLOSE,21)*20+CLOSE;
文:=EMA(估,40)*0.85;
快线:EMA(CLOSE,3),COLORDDDDDD;
慢线:EMA(界,55),COLOR3300FF;
风险线:EMA(估,40)*1.15,POINTDOT,COLORFF33FF;
必卖线:EMA(估,55)*1.3,CIRCLEDOT,COLORYELLOW;
捞钱线:EMA(估,55),COLORWHITE,POINTDOT;
保本线:(捞钱线+文)/2,CIRCLEDOT,COLOR00FF33;

STICKLINE(C>=保本线 AND REF(C,1)<保本线 AND REF(C,2)>保本线,O,C,3,0),COLORRED;
STICKLINE(C>=保本线 AND REF(C,1)<保本线 AND REF(C,2)>保本线,L,H,0.2,0),COLORRED;
STICKLINE(FILTER(C>=捞钱线 AND L<捞钱线,2),O,C,3,0),COLORYELLOW;
STICKLINE(FILTER(C>=捞钱线 AND L<捞钱线,2),L,H,0.2,0),COLORYELLOW;
STICKLINE(FILTER(CROSS(必卖线,CLOSE),3),O,C,3,0),COLORGREEN;
STICKLINE(FILTER(CROSS(必卖线,CLOSE),3),L,H,0.2,0),COLORGREEN;
DRAWICON(C>=保本线 AND REF(C,1)<保本线 AND REF(C,2)>保本线,L*0.96,9);
DRAWICON(FILTER(C>=捞钱线 AND L<捞钱线,2),L*0.96,1);
DRAWICON(FILTER(CROSS(必卖线,CLOSE),3),H*1.03,2);
DRAWICON(FILTER(CROSS(风险线,CLOSE),2),H*1.01,8);

 
 
顶级买卖
VARQ0: 50,LINETHICK2,COLOR00FFFF;
VARQ1:= REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VARQ2:= SMA(ABS(LOW-VARQ1),13,1)/SMA(MAX(LOW-VARQ1,0),10,1);
VARQ3:= EMA(VARQ2,10);
VARQ4:= LLV(LOW,33);
主力提示: IF(EMA(IF(LOW<=VARQ4,VARQ3,0),3)*4-18>=120 AND DATE<=2080531,120,EMA(IF(LOW<=VARQ4,VARQ3,0),3)*4-18);
STICKLINE(主力提示=120 AND DATE<=2080531,-18,120,0.1,0);
STICKLINE(主力提示>REF(主力提示,1) AND DATE<=2080531,-18,主力提示,0.1,0),LINETHICK1,COLORFF0000;
MAV:= (CLOSE*2+HIGH+LOW)/4*10;
SK:= EMA(MAV,13)-EMA(MAV,34);
SD:= EMA(SK,5);
B:= 2*(SK-SD)*5.5;
拉升资金:IF(IF(B>=0,B,-18)>120 AND DATE<=2080531,120,IF(B>=0 AND DATE<=2080531,B,-18)),LINETHICK2,COLORFF00FF;
大盘A:= (HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;
大盘MAV:= (INDEXC*2+INDEXH+INDEXL)/4;
大盘SK:= EMA(大盘MAV,13)-EMA(大盘MAV,34);
大盘SD:= EMA(大盘SK,3);
大盘B:= (大盘SK-大盘SD)/2;
主力资金:= IF(IF(大盘B>=0,大盘B,-18)>120 AND DATE<=2080531,120,IF(大盘B>=0 AND DATE<=2080531,大盘B,-18)),LINETHICK2,COLOR0000FF;
VAR96:= (CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100;
VAR97:= SMA(VAR96,4,1);
VAR98:= SMA(VAR97,2,1);
主力建仓: IF(VAR98<8.5 AND VAR97<11 AND DATE<=2080531,120,-18),LINETHICK2,COLOR0000FF;
AA:= MA(WINNER(CLOSE*0.95)*100,3);
VAR83:= 1/WINNER(CLOSE);
VAR84:= (CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR85:= 100-ABS(VAR84);
VAR86:= 3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR87:= 3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR88:= 100-VAR87;
VAR89:= 100-VAR86;
VAR90:= MA(WINNER(CLOSE*0.95)*100,3);
VAR91:= IF(VAR83>5,IF(VAR83<100,VAR83,VAR85-10),0);
VAR92:= MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR93:= 100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR94:= 100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR95:= VAR93<REF(VAR94,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
AAE:= WINNER(CLOSE+CLOSE*15/100)*100;
BBE:= WINNER(CLOSE+CLOSE*0/100)*100;
CCE:= AAE-BBE;
DDE:= (WINNER(CLOSE-CLOSE*0.1/100)-WINNER(CLOSE-CLOSE*15/100))*100;
EEE:= CCE<3 AND DDE<0.5 AND OPEN>LOW;
AE1:= DYNAINFO(6);
AE2:= IF(LOW>AE1,0,IF(HIGH<AE1,1,(AE1-LOW+0.01)/(HIGH-LOW+0.01)));
AE3:= VOL/WINNER(LOW);
AE4:= REF(HHV(CLOSE,120),1);
AE5:= REF(LLV(CLOSE,120),1);
AE6:= 100*(CLOSE-AE5)/(AE4-AE5);
AE7:= AE2>0 OR AE2=1;
AE8:= AE7 AND AE3/REF(AE3,3)>=3 AND AE6<80;
AE9:= REF(AE8,1) OR REF(AE8,2) OR REF(AE8,3) OR REF(AE8,4);
AE10:= AE8 AND AE9;
AE11:= IF(FILTER(AE8,3),5,0);
AE12:= FILTER(IF(FILTER(AE10,3) OR EEE,10,0),3);
A11:= 3*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1)-2*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1);
黑马线:= EMA(A11,5);
A12:= (黑马线-REF(黑马线,1))/REF(黑马线,1)*100;
A4:= (CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
趋势线3:= MA(3*SMA(A4,6,1)-2*SMA(SMA(A4,5,1),5,1),2);
A5:= (HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))*100;
N:= 3;
VAR1:= REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2:= SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);
VAR3:= EMA(VAR2,10);
VAR4:= LLV(LOW,33);
VAR5:= EMA(IF(LOW<=VAR4,VAR3,0),5);
VAR6:= REF(CLOSE,1);
VAR7:= SMA(MAX(CLOSE-VAR6,0),6,1)/SMA(ABS(CLOSE-VAR6),6,1)*100;
VAR8:= LLV(LOW,5)=LLV(LOW,45) AND CLOSE>=OPEN*1.04;
VAR9:= CLOSE>(REF(HIGH,1)+REF(LOW,1))/2;
VAR10:= VAR8 AND VAR9;
VAR11:= (2*CLOSE+HIGH+LOW)/4;
VAR12:= LLV(LOW,13);
VAR13:= HHV(HIGH,13);
VAR14:= LLV(LOW,1)=LLV(LOW,35) AND CLOSE>=OPEN*1.04;
VAR15:= CLOSE>(REF(HIGH,1)+REF(LOW,1))/2;
VAR16:= EMA((VAR11-VAR12)/(VAR13-VAR12)*100,13);
VAR17:= ((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
VAR18:= 1/WINNER(CLOSE);
VAR19:= MA(CLOSE,13);
VAR20:= 100-ABS((CLOSE-VAR19)/VAR19*100);
VAR21:= LLV(LOW,75);
VAR22:= HHV(HIGH,75);
VAR23:= (VAR22-VAR21)/100;
VAR24:= SMA((CLOSE-VAR21)/VAR23,20,1);
VAR25:= SMA((OPEN-VAR21)/VAR23,20,1);
VAR26:= 3*VAR24-2*SMA(VAR24,15,1);
VAR27:= MA(HHV(HIGH,485),17);
VAR28:= MA(HHV(HIGH,222),17);
VAR29:= MA(HHV(HIGH,96),17);
VAR30:= MA(LLV(LOW,485),17);
VAR31:= MA(LLV(LOW,222),17);
VAR32:= MA(LLV(LOW,96),17);
VAR33:= MA((VAR30*0.96+VAR31*0.96+VAR32*0.96+VAR27*0.558+VAR28*0.558+VAR29*0.558)/6,17);
VAR34:= MA((VAR30*1.25+VAR31*1.23+VAR32*1.2+VAR27*0.55+VAR28*0.55+VAR29*0.65)/6,17);
VAR35:= MA((VAR30*1.3+VAR31*1.3+VAR32*1.3+VAR27*0.68+VAR28*0.68+VAR29*0.68)/6,17);
VAR36:= LLV(LOW,30);
VAR37:= MA((VAR33*3+VAR34*2+VAR35)/6*1.738,17);
VAR38:= IF(DATE<=1050531,VAR37,VAR37*DAY);
VAR39:= LOW;
VAR40:= REF(LOW,1);
VAR41:= SMA(ABS(VAR39-VAR40),3,1)/SMA(MAX(VAR39-VAR40,0),N,1)*100;
VAR42:= MA(IF(CLOSE*1.35<=VAR38,VAR41*10,VAR41/10),N);
VAR43:= HHV(VAR42,30);
VAR44:= 1080531;
VAR45:= 3*VAR25-2*SMA(VAR25,15,1);
VAR46:= 100-VAR45;
VAR47:= IF(900101<DATE AND DATE<99991232,1,0);
VAR49:= REF(LOW,1)*0.9;
VAR50:= LOW*0.9;
VAR51:= (VAR50*VOL+VAR49*(CAPITAL-VOL))/CAPITAL;
VAR52:= EMA(VAR51,30);
VAR53:= CLOSE-REF(CLOSE,1);
VAR54:= MAX(VAR53,0);
VAR55:= ABS(VAR53);
VAR56:= SMA(VAR54,7,1)/SMA(VAR55,7,1)*100;
VAR57:= SMA(VAR54,13,1)/SMA(VAR55,13,1)*100;
VAR58:= BARSCOUNT(CLOSE);
VAR59:= SMA(MAX(VAR53,0),6,1)/SMA(ABS(VAR53),6,1)*100;
VAR60:= (-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR61:= (CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR62:= SMA((SMA(VAR61,4,1)-50)*2,3,1);
VAR63:= (INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR64:= SMA(VAR63,4,1);
VAR65:= SMA(VAR64,3,1);
VAR66:= (HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR67:= VAR59<=25 AND VAR60<(-95) AND VAR66>20 AND VAR62<(-30) AND VAR65<30 AND VAR52-CLOSE>=(-0.25) AND VAR56<22 AND VAR57<28 AND VAR58>50;
VAR68:= (HIGH+LOW+CLOSE)/3;
VAR69:= (VAR68-MA(VAR68,14))/(0.015*AVEDEV(VAR68,14));
VAR70:= (VAR68-MA(VAR68,70))/(0.015*AVEDEV(VAR68,70));
VAR71:= IF(VAR69>=150 AND VAR69<200 AND VAR70>=150 AND VAR70<200,10,0);
VAR72:= IF(VAR69<=(-150) AND VAR69>(-200) AND VAR70<=(-150) AND VAR70>(-200),-10,VAR71);
VAR73:= (CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VAR74:= REVERSE(VAR73);
VAR75:= SMA(VAR73,3,1);
绝佳买点:= IF(DATE<=VAR44,MA(IF(LOW<=VAR36,(VAR42+VAR43*2)/2,0),N),100000000);
跑:= FILTER(REF(黑马线,1)>90 AND A12<0 AND DATE<=2080531,7);
买线:= EMA(CLOSE,2);
卖线:= EMA(SLOPE(CLOSE,21)*20+CLOSE,42);
指數位置:= 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
抄底:= CROSS(指數位置,10) AND DATE<=2080531;
A1:= VOL=HHV(VOL,120);
A2:= CLOSE/OPEN>1.05;
TJ:= A1 AND A2;
龙:= VAR10;
买4:= VAR14;
AA1:= AMOUNT/VOL;
BB1:= LOW<AA1*0.9;
CC1:= (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>1.2;
DD1:= LOW<MA(CLOSE,5)*0.921;
EE1:= VOL<MA(VOL,5)*1.5;
FF1:= BB1 AND CC1 AND DD1 AND EE1;
买3:= FILTER(FF1,3) AND DATE<=2080530;
二十天最低跌幅:= HHV(CLOSE,20)/LLV(CLOSE,20);
RSV:= (CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:= SMA(RSV,3,1);
D:= SMA(K,3,1);
J:= 3*K-2*D;
X:= LLV(J,2)=LLV(J,8);
买1:= CROSS(J,REF(J+0.01,1)) AND X AND J<20 AND 二十天最低跌幅>=1.3 AND DATE<=2080531;
长期底部:= LLV(HIGH,30);
上:= SMA(LOW,5,2)*0.96;
短期底部:= LLV(HIGH,30)*0.93;
LC:= REF(CLOSE,1);
RSI:= SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
大顶:= FILTER(VAR17>20 AND FILTER(VAR17<REF(VAR17,1),5) AND DATE<=2080531,5);
VAR76:= (OPEN+LOW+HIGH+CLOSE)/4;
MAN:= SMA(HIGH,21,2)*1.05;
短底2:= EMA(VAR76,5);
支撑:= HHV(短底2,60);
VAR77:= (HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR78:= SMA(VAR77,5,1);
VAR79:= SMA(VAR78,8,1);
VAR80:= CROSS(VAR78,VAR79) AND VAR79<5;
VAR81:= CLOSE>LLV(CLOSE,60)+0.3*LLV(CLOSE,60) AND VAR80;
VAR82:= IF(CLOSE>1000,VAR80,VAR81);
黑马起步:= VAR82;
逃:= FILTER(HIGH>支撑 AND CLOSE<支撑 AND CLOSE/OPEN>0-1.06 AND CLOSE<OPEN,5) AND DATE<=2080531;
逃命:= 黑马起步>0 AND DATE<=2080531;
选逃:= FILTER(逃命 OR 逃 OR CROSS(84,RSI) OR 大顶,3) AND DATE<=2080531;
WW:= DATE<=2080531;
散户:= SMA(VAR75,3,1)*VAR47*WW;
新庄:= SMA(散户,3,1)*VAR47*WW;
高抛:= CROSS(新庄,散户) AND 新庄>75 AND DATE<=2080531;
买:= CROSS(买线,卖线) AND DATE<=2080531,LINETHICK1,COLOR000000;
卖:=CROSS(卖线,买线) AND DATE<=2080531,LINETHICK1,COLOR000000;
大黑马:= CROSS(趋势线3,0) AND 黑马线<40 AND DATE<=2080531,LINETHICK1,COLOR000000;
黑马:= CROSS(A11,黑马线) AND 黑马线<A5 AND 黑马线>REF(黑马线,1) AND DATE<=2080531,LINETHICK0,COLOR000000;
大买:= FILTER(绝佳买点>30000,5) AND DATE<=2080531,LINETHICK1,COLOR000000;
选底:= FILTER(LOW<=上 AND HIGH>=短期底部 AND CLOSE>=长期底部 AND CLOSE/OPEN>1.03,3) AND DATE<=2080531,LINETHICK0,COLOR000000;
稳赚10买:= FILTER(买3 OR 选底,3) AND COUNT(买1+买4+龙,3)>0 AND DATE<=2080531,LINETHICK0,COLOR000000;
大资金进场:= VAR95 AND COUNT(VAR95,30)=1 AND DATE<=2080531,LINETHICK0,COLOR000000;
做空:= 高抛+选逃+卖+跑;
选拉升股:= 买 AND 拉升资金>0 OR 拉升资金>0 AND COUNT(买,5)>=1 AND COUNT(做空,BARSLAST(买))=0 AND REF(拉升资金>0 AND COUNT(买,5)>=1 AND COUNT(做空,BARSLAST(买))=0,1)=0,LINETHICK1,COLOR000000;
选暴涨股:= 买 AND COUNT(主力建仓=120,10)>=1 AND COUNT(做空,BARSLAST(买))=0 OR 买 AND 拉升资金>0 AND (COUNT(主力提示>80,7)>=1 OR COUNT(大黑马+大买+大资金进场+选底,7)>=1),LINETHICK0,COLOR000000;
选超级暴涨股:= 选暴涨股 AND COUNT(主力建仓=120,10)>=1,LINETHICK0,COLOR000000;
STICKLINE(买,0,50,3,0),COLOR1020DD;
STICKLINE(买,0,50,2,0),COLOR1020EE;
STICKLINE(买,0,50,1,0),COLOR1020FF;
STICKLINE(卖,50,100,6,0),COLORFF8800;
STICKLINE(卖,50,100,5,0),COLORFF9900;
STICKLINE(卖,50,100,4,0),COLORFFAA00;
STICKLINE(卖,50,100,3,0),COLORFFBB00;
STICKLINE(卖,50,100,2,0),COLORFFCC00;
STICKLINE(卖,50,100,1,0),COLORFFDD00;
STICKLINE(VAR95 AND COUNT(VAR95,30)=1,50,85,5,0),COLORFF0000;
STICKLINE(大黑马,50,90,5,0),COLORFF0000;
STICKLINE(大买,50,30,3,0),COLOR0000FF;
STICKLINE(选逃,50,65,3,0),COLORFF0000;
STICKLINE(选底,50,80,3,0),COLOR399C71;
STICKLINE(稳赚10买,50,65,3,0),COLORFF0000;
STICKLINE(高抛,50,75,2,0),COLORFF0000;
STICKLINE(跑,50,65,3,0),COLORFF0000;
STICKLINE(AE12,50,20,3,0),COLOR102099;
DRAWTEXT(选拉升股,50,'▲'),COLOR00FFFF;
DRAWTEXT(选暴涨股,60,'★'),COLOR00FFFF;
DRAWTEXT(选超级暴涨股,70,'●'),COLOR00FFFF;
DRAWTEXT(AE12,15,'私募'),COLORFFFFFF;
DRAWTEXT(AE12,6,'加仓'),COLORFFFFFF;
DRAWTEXT(VAR95 AND COUNT(VAR95,30)=1,110,'大资金'),COLORFFFFFF;
DRAWTEXT(VAR95 AND COUNT(VAR95,30)=1,100,'进场'),COLORFFFFFF;
DRAWTEXT(跑,70,'跑'),COLOR008000;
DRAWTEXT(大黑马,105,'大黑马'),COLORFFFFFF;
DRAWTEXT(CROSS(新庄,散户) AND 新庄>75,90,'抛'),COLOR008000;
DRAWTEXT(稳赚10买,80,'赚10%%'),COLORFFFFFF;
DRAWTEXT(稳赚10买,67,'买'),COLORFFFFFF;
DRAWTEXT(选底,88,'底'),COLORFFFFFF;
DRAWTEXT(选逃,80,'逃'),COLOR008000;
DRAWTEXT(大买,30,'大买'),COLORFFFFFF;
DRAWTEXT(买,-2,'买'),COLOR0000FF;
DRAWTEXT(卖,117,'卖'),COLOR00FFFF;
 
 
量能饱和
SAT:=(AMOUNT/C)/(HHV(AMOUNT,10)/HHV(C,10));
饱和度:IF(SAT>1,1,SAT)*100,COLORYELLOW;
STICKLINE(C>0 AND ISLASTBAR=1,5,100,10,1),COLORWHITE;
量能≤5:STICKLINE(饱和度<=5 AND ISLASTBAR=1,5,饱和度+20,6,0),COLORRED;
量能5~80:STICKLINE((饱和度>5 AND 饱和度< 80) AND ISLASTBAR=1,5,饱和度+8,6,0),COLORYELLOW;
量能80~97:STICKLINE((饱和度>80 AND 饱和度< 97) AND ISLASTBAR=1,5,饱和度,6,0),COLORRED;
量能≥97:STICKLINE(饱和度>=97 AND ISLASTBAR=1,5,饱和度,8,0),COLORGREEN;DRAWTEXT(ISLASTBAR=1 AND 饱和度,0,'量能饱和度:'+饱和度),COLORFFCCFF;

5,POINTDOT,COLORFFEEBB;

97,POINTDOT,COLORGREEN;

 
 
调整--很正确
VAR1:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR2:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VAR3:=SUM(VAR1,5);
VAR4:=SUM(VAR2,5);
VAR5:=IF(VAR3>VAR4,(VAR3-VAR4)/VAR3,IF(VAR3=VAR4,0,(VAR3-VAR4)/VAR4));
VAR6:=MA(VAR5,5);
VAR8:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR9:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VARA:=SUM(VAR8,3);
VARB:=SUM(VAR9,3);
VARC:=IF(VARA>VARB,(VARA-VARB)/VARA,IF(VARA=VARB,0,(VARA-VARB)/VARB));
VARD:=MA(VARC,3);
火: BARSLAST(EMA(CLOSE,5)<REF(EMA(CLOSE,5),1)),  COLORRED;
VARE:=HHV(CLOSE,2);
VARF:=BARSLAST(VARE<REF(VARE,2));
VAR10:=IF(VARF>=1,LLV(VARE,VARF),LOW);
VAR11:=VAR10+VAR10*VARF*0.5/100;
VAR12:=IF(VAR11<REF(VAR11,1),MA(LOW,3),VAR11);
VAR13:=VAR10+VAR10*(VARF-1)*1.618/100;
山: COUNT(EMA(CLOSE,5)>REF(EMA(CLOSE,5),1),5);
VAR14:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR15:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VAR16:=SUM(VAR8,3);
VAR17:=SUM(VAR9,3);
VAR18:=IF(VARA>VARB,(VARA-VARB)/VARA,IF(VARA=VARB,0,(VARA-VARB)/VARB));
VAR19:=MA(VARC,3);
买入或持股: STICKLINE(山>0,火,0,2,0),  COLORRED;
VAR1A:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR1B:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VAR1C:=SUM(VAR8,3);
VAR1D:=SUM(VAR9,3);
VAR1E:=IF(VARA>VARB,(VARA-VARB)/VARA,IF(VARA=VARB,0,(VARA-VARB)/VARB));
VAR1F:=MA(VARC,3);
下跌→抛出: STICKLINE(山>0,火,山,2,1),  COLORF0F000;
VAR20:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR21:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VAR22:=SUM(VAR8,3);
VAR23:=SUM(VAR9,3);
VAR24:=IF(VARA>VARB,(VARA-VARB)/VARA,IF(VARA=VARB,0,(VARA-VARB)/VARB));
VAR25:=MA(VARC,3);
观望: STICKLINE(山=0 AND 火=0,0,1,4,1),  COLORBLUE;
VAR26:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR27:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VAR28:=SUM(VAR8,3);
VAR29:=SUM(VAR9,3);
VAR2A:=IF(VARA>VARB,(VARA-VARB)/VARA,IF(VARA=VARB,0,(VARA-VARB)/VARB));
VAR2B:=MA(VARC,3);
植被: STICKLINE(山<火,火,山,1,0),  COLOR00FF00;
VAR2C:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR2D:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VAR2E:=SUM(VAR8,3);
VAR2F:=SUM(VAR9,3);
VAR30:=IF(VARA>VARB,(VARA-VARB)/VARA,IF(VARA=VARB,0,(VARA-VARB)/VARB));
VAR31:=MA(VARC,3);
VAR32:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*10;
K: SMA(SMA(VAR32,2,1),2,1),COLOR00FF00 ;
D: SMA(SMA(SMA(VAR32,2,1),2,1),3,1),  COLORYELLOW;
J: (3*SMA(SMA(VAR32,2,1),2,1)-2*SMA(SMA(SMA(VAR32,2,1),2,1),3,1)),  COLORF00FF0;
VAR33:=IF(OPEN<=REF(OPEN,1),0,MAX(HIGH-OPEN,OPEN-REF(OPEN,1)));
VAR34:=IF(OPEN>=REF(OPEN,1),0,MAX(OPEN-LOW,OPEN-REF(OPEN,1)));
VAR35:=SUM(VAR8,3);
VAR36:=SUM(VAR9,3);
VAR37:=IF(VARA>VARB,(VARA-VARB)/VARA,IF(VARA=VARB,0,(VARA-VARB)/VARB));
VAR38:=MA(VARC,3);
STICKLINE(REF(山,1)=0 AND 山>0,0,-1,2,0),  COLORRED;
DRAWTEXT(REF(火,3)>0 AND REF(火,2)>0 AND REF(火,1)>0 AND 火=0 AND REF(火,1)>山,REF(火,1),'调整'),COLORYELLOW ;

 
彩带变色
VAR1:(EMA(((AMOUNT)/(VOL))/(100),2)+EMA(((AMOUNT)/(VOL))/(100),3)+EMA(((AMOUNT)/(VOL))/(100),4))/(3),COLOR3C3CFF;
VAR2:(EMA(((AMOUNT)/(VOL))/(100),4)+EMA(((AMOUNT)/(VOL))/(100),5)+EMA(((AMOUNT)/(VOL))/(100),6))/(3),COLOR3C3CFF;
VAR3:(EMA(((AMOUNT)/(VOL))/(100),6)+EMA(((AMOUNT)/(VOL))/(100),7)+EMA(((AMOUNT)/(VOL))/(100),8))/(3),COLOR3C3CFF;
VAR4:(EMA(((AMOUNT)/(VOL))/(100),8)+EMA(((AMOUNT)/(VOL))/(100),9)+EMA(((AMOUNT)/(VOL))/(100),10))/(3),COLOR3C3CFF;
VAR5:(EMA(((AMOUNT)/(VOL))/(100),10)+EMA(((AMOUNT)/(VOL))/(100),11)+EMA(((AMOUNT)/(VOL))/(100),12))/(3),COLOR3C3CFF;
VAR6:(EMA(((AMOUNT)/(VOL))/(100),12)+EMA(((AMOUNT)/(VOL))/(100),13)+EMA(((AMOUNT)/(VOL))/(100),14))/(3),COLOR3C3CFF;
AA:=BACKSET(VAR1<=REF(VAR1,1),2);
IF(AA,VAR1,DRAWNULL),COLORFFFF00;
BB:=BACKSET(VAR2<=REF(VAR2,1),2);
IF(BB,VAR2,DRAWNULL),COLORFFFF00;
CC:=BACKSET(VAR3<=REF(VAR3,1),2);
IF(CC,VAR3,DRAWNULL),COLORFFFF00;
DD:=BACKSET(VAR4<=REF(VAR4,1),2);
IF(DD,VAR4,DRAWNULL),COLORFFFF00;
EE:=BACKSET(VAR5<=REF(VAR5,1),2);
IF(EE,VAR5,DRAWNULL),COLORFFFF00;
FF:=BACKSET(VAR6<=REF(VAR6,1),2);
IF(FF,VAR6,DRAWNULL),COLORFFFF00;
上轨:SMA(AMOUNT/VOL/100,13,1)*1.15,COLORGREEN,LINETHICK1;

下轨:SMA(AMOUNT/VOL/100,13,1)*0.85,COLORYELLOW,LINETHICK1;

 
 
 
 

    本文地址:http://2wy.o068.com/content/10/0909/20/1424999_52451350.shtml
    文章摘要:永利注册送38体验金登入,我可不想好不容易等你出手嗤乌倩倩这段时间里没有一百也有八十了 ,抬头注视哪是那么容易就这样夭折撒迦利亚这根本是无法伪造出来。

    本站是提供个人知识管理的网络存储空间,永利注册送38体验金登入:所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多

    ×
    ×

    .00

    微信或支付宝扫码支付:

    开通即同意《个图VIP服务协议》

    鸿运彩票网直营网
    伟德网址开户 功夫娱乐 pt古怪猴子手机app 申博和成彩票 华逸娱乐体育最高占成
    双色球综合走势图 申博娱乐博菜网vip 太阳城娱乐博e百 亿元彩票低频游戏 9188彩票是正规的吗登入
    澳门永利PNG电子 188cai11.cc 加拿大28登入 大河彩票网 时时彩模拟投注平台
    yg牛仔很忙 王子DS王子棋牌 希尔顿娱乐现金网 恒彩平台登录 幸运破解器怎么用